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Welcome to XMetaL Author

XMetal Author is a graphical editor for creating and editing structured documents. It provides a highly
configurable user interface and a powerful array of authoring tools. You can use XMetal to create XML
documents in any language, regardless of your XML knowledge.

The user interface features multiple document views, customizable toolbars, and tear-off menus. The Resource
Manager provides drag-and-drop management of text blocks, images, and other assets.

You can tailor XMetal Author to fit your organization’s workflow and graphical standards through
customizations. A sample customization, Journalist, is provided as an example. Customizations determine
how your information is presented and much of the authoring functionality.

With support for DITA topics, maps, specializations and the DITA Open Toolkit, XMetaL Author continues its
support for this industry standard. Assisted authoring features including enhanced menus, toolbars, dialog
boxes, and styling and editing behaviors, let you create and publish DITA content out-of-the-box.

XMetal also provides the flexibility for integrating with any source control system, database, repository, or
content management system.

Other XMetaL publications

APIs and other programming features such as scripts, forms, controls, and macros are described in the
XMetal Programmer’s Guide. The XMetaL Customization Guide describes how to create and deploy
customizations. These publications are distributed with XMetalL Developer and are available for download
from the JustSystems website at http://na.justsystems.com.

Feedback

Send your comments or questions about XMetaL documentation to XMetal Support.

Copyright

© 2023 JustSystems Canada, Inc. All rights reserved.
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Quick tour

The user interface provides access to all editing operations and allows you to create a custom environment
that is tailored to your preferences. You can select a preferred view and choose panes and toolbars to
frequently used tasks.

Getting help

Context-sensitive Help is provided in all XMetalL Author dialogs. You can also access online Help and search
for information through the Help menu.

When you are working in a DITA document, you can view the Help topic for the current element in the DITA
Language Reference through Help > Help on Current Element.

Sample files

Sample files are provided to demonstrate various aspects of XMetalL Author functionality. When a document
is open, you can view sample files through Help > Samples. A sample DITA map file is also provided.

Your working copies of the sample files are saved to the following location:
YAPPDATA% Sof t Quad\ XMet aL\ <ver si on>\ Sanpl es. You can restore the sample files by deleting this
folder and re-opening the sample files.

DITA references

The following DITA reference information is available through the Help menu:

« XMetalL Evaluation Guide. Covers basic information about creating DITA topics and maps as well as
background information about structured authoring and the advantages of using DITA.

» DITA Language Reference. Describes the purpose of each DITA element and the rules associated with
it. Includes usage examples.

» DITA Architectural Specification. The OASIS DITA specification. Describes DITA markup, processing,
and specialization. Also provides background information on terminology and the DITA DTD/schema.

» DITA Open Toolkit User Guide. Describes the Java-based implementation of the OASIS DITA specification,
including processing targets such as HTML and PDF.

Document views

You can choose a view for your document through the View menu or from the view buttons in the document
status bar. The view you select depends on how you want to work with your document. You can set view
options, including a default view through Tools > Options.

v

[ - T e =
/JU o|B] & [Aricle / Sectl / Title

© 2023 JustSystems Canada, Inc. 10



Document views

Normal view

In Normal view, your documents appear similar to how they would appear in a word processor. Only the
content of your document is visible; the underlying markup is not displayed. Formatting is determined by a
Cascading Style Sheet. Structured authoring commands are available from the menus, and rules checking
is active.

) CamerasinFocus.xmi

Introduction

‘The newest generation of affordable, high- resolution digital cameras delivers prints that are
nearly indistinguishable from traditional film based photos. Over the past vear, the entry
level $500 digital camera has gone from a 640 by 480 resolution that delivered a reasonable
4 by 6 inch print to a 1,280 by 1,024 resolution that delivers an excellent 5 by 7 inch print.

In this roundup, we selected cameras that delivered:
+ Megapixel resolution - more than one million picture elements per image
+ Removable Media - to make transfer to PCs faster and easier
¢ Built In Flash - recommended for crisp, balanced indoor pictures

Dlgltal cameras have a number of advantages over traditional film based cameras. Not only is

rﬂmwnswﬁwﬁquww

Tags On view

In Tags On view, both the content and markup (for example, element start and end tags) of your document
are visible. This view is useful for navigating the element hierarchy and positioning the insertion point.
Formatting is determined by a Cascading Style Sheet. Structured authoring commands are available from
the menus, and rules checking is active.

Here are some of the features available in Tags On view:
* You can select an entire element by clicking its start or end tag.

* You can collapse or expand tags through the right-click menu.
« You can view all set attributes by resting the pointer over a tag.

P

CamerasinF ocus.xml

am> Introduction am
[ZFe>The newest generation of affordable, high- resolution digital cameras delivers prints
that are nearly indistinguishable from traditional film based photos. Over the past vear, the
entry level $500 digital camera has gone from a 640 by 480 resolution that delivered a
reasonable 4 by 6 inch print to a 1,280 by 1,024 resolution that delivers an excellent 5 by 7
ineh print.
[ZPara> In this roundup, we selected cameras that delivered:

« (LB (TP Megapixel resolution - more than one million picture elements per

image (FPara) {[sttem)
« [CLElem> CTRar> Removable Media - to make transfer to PCs faster and easier
« [E[Litien» [EFara» Built In Flash - recommended for crisp, balanced indoor pictures

[ZPara > Digital cameras have a number of advantages over traditional film based cameras.

“~Not gy, is abere nofilm - ==ng, csts.hutabsq dish a2 useppoaphiageehaine ot

© 2023 JustSystems Canada, Inc. 11



Specify tag and tag text colors

Plain Text view

In Plain Text view, the markup and content of your document are displayed as text only. Rules checking is
not active in Plain Text view, and you are not prevented from entering invalid markup. However, you can still
validate your document.

& . ) . .
"2/ Note: Not all commands are available in Plain Text view.
Plain Text view is color-coded so that you can easily identify elements, attributes, and text. You can set plain

text view options, including line numbering, colors, and wrapping.

If you enter markup characters (for example, ‘<’, ‘>, and ‘&’) in Plain Text view, they are interpreted as markup
when you switch to another view. If you want to prevent the characters from being interpreted as markup,
you need to enclose them in a CDATA section.

Page Preview

Page Preview allows you to view your document using a Web browser. This view is read-only; you cannot
edit your document in Page Preview. Formatting is determined by a Cascading Style Sheet.

E N
"2 Note: The default browser is Microsoft Internet Explorer.

To do this Follow these steps

View a document using the default browser Click View > Page Preview

View a document using a browser Click File > Preview in Browser and select a browser

Add a browser to the list of available browsers Click File > Preview in Browser, click Add and select a
browser

Remove a browser from the list of available browsers Click File > Preview in Browser, select a browser and click
Delete

P

=/ Tip: You can also use the Preview toolbar to view a document using a selected browser. Click a blank
Preview toolbar button to associate it with a Web browser.

Related Links
Options on page 49
You can set options through the Tools menu.

Inserting CDATA sections on page 124
You can insert CDATA sections using the Insert menu.

Authoring structured content on page 100
When you create a document instance of a DTD or Schema in Normal or Tags On view, XMetaL
Author ensures that your content is valid by guiding you through the authoring process. You do not
need to have a complete understanding of XML to begin authoring structured content.

Specify tag and tag text colors

1. Click Tools > Options and click the View tab.
2. Click one of the following:

e Foreground (for tag text)
« Background (for tag background)
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Structure View

Options .)T|
| General | View | Plain Tesd View | Fie Change Tracking

Open new documants in Tag leons

) Plain Texd View Fort-

() Tags On View Anal L

(%) Nermal View Sze:

B -
[+#] Shivw iriine images il (I Foreground .-'I
\
[#] Show commeris D E&:‘k’;‘ﬂl-l’lﬂ }
[[]'Show Stnuctune View by default 0o 20 Tag koors

3. Choose a color.

@ Tip: You can specify custom tag and text colors by creating a custom palette.

Structure View

Structure View displays the overall structure or information hierarchy of the document. You can select Structure
View from the View menu.

Structure View inherits the styles of the main document. It also has its own style sheet for each DTD or
Schema that you use.

In Structure View, you can insert, cut, paste, copy, and drag-and-drop elements.

) CamerasinFocus. xmi r-_lralril
-

oy T eaLseiin

B Sectt .
g Introduc IIntruductmn

[E The newest gen The newest generation of affordable, high- resolution digital
& In this roundup cameras delivers prints that are nearly indistinguizhable from

£ 0 remizedList traditional film based photos. Over the past year, the entry level
=@ £500 digital camera has gone from a 640 by 480 resolution that
M . delivered a reasonable 4 by 6 inch print to a 1,280 by 1,024
@ = Megapixe. resplution that delivers an excellent 5 by 7 inch print.
B & Removabl In this roundup, we selected cameras that delivered:
=la - + Megapixel resolution - more than one million picture
& Built In F1 elements per image

A Disigabsa neras . ,;.Bemm'ab]e Media - 5? 5@:9 tranii:er to P {,_raster a_ni .

Related Links
Customizing the user interface on page 25
You can customize the user interface to give you quick access to tasks and assets. You can make
your changes available to all users or reserve them for your use only. Likewise, your changes can
apply only to documents that use a specific DTD or Schema, or to all documents.
Options on page 49
You can set options through the Tools menu.
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Panes

Panes

14

Panes provide access to the markup in your document and let you organize resources. You can have one
or more panes open in your work area at any time. You can dock a pane so that it is attached to the work
area border, or the pane can float. You can pin a pane to keep it open, or un-pin a pane to hide it.

To do this

Follow these steps

Show/hide a pane

Dock a pane

Un-dock a pane (make it
float)

Pin a pane

Un-pin (auto hide) a pane

¢ Click the View menu and select a pane to show or hide it, or
Right-click on the pane header (or click the Window Position icon), and select Hide
from the menu to hide a menu.

Double-click the title bar, or

Click and hold the title bar, and then drag the pane to its docked position, or
Right-click on the pane header (or click the Window Position icon), and select Docking
from the menu.

When you are docking a pane, docking hotspot indicators appear. While dragging
a pane, you may move your mouse cursor over one of the indicators. When you
release the mouse, the pane you are docking will snap to the indicated docking
position.

« Double-click the title bar, or
¢ Click the title bar and drag the pane from its docked position, or

« Right-click on the pane header (or click the Window Position icon), and select Floating
from the menu.

Click the sideways pin (pins are displayed sideways when a pane is un-pinned)

« Click the upright pin (pins are displayed upright when a pane is pinned), or
« Right-click on the pane header (or click the Window Position icon), and select Auto
hide from the menu.

When a pane is un-pinned, placing the cursor on the pane's tab slides open the
pane.

The following panes are available:
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Panes

 Attribute Inspector. Displays the attributes for the current element and lets you set attribute values.

Attribute Inspector

[

audience

| base

conaction

conkeyref

connef

| conrefend

delivery Tanget

dir

|id i_ODBD25ED325BC4FC2ABI3BE41610E

importance

otherprops

| outputclass

platfam

?:-.ttribute Inspectar | = Element List

To do this

Follow these steps

Sort attributes alphabetically

of the list

the top of the list

Sort attributes by displaying required attributes at the top

Sort attributes by displaying those that include a value, at 1

1. Hover the mouse over the Attribute Inspector pane.
2. Right-click to display the action menu.
3. Select Sort Attributes.

Hover the mouse over the Attribute Inspector pane.

Right-click to display the action menu.

NOTE: Secondary sorting is alphabetically 3. Select Sort Attributes (Required First).

Hover the mouse over the Attribute Inspector pane.
Right-click to display the action menu.

NOTE: Secondary sorting is alphabetically 3. Select Sort Attributes (Value First).

« Element List. Lets you insert or change elements in your document. In Normal and Tags On views, displays
the list of elements that are valid at the insertion point (All tab), or the list of elements that are valid at the
insertion point and are currently used in your document (Used tab). Elements that are required in the current
context are displayed in bold. In Plain Text view, all elements are displayed.

© 2023 JustSystems Canada, Inc.
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Panes

Element List x

| Used | Al |

codeph
image
indexterm
menucascade
note

p

table

uicontrol

ul

" Change ™ Insert Apply
old

Attribute Inspector | Element List | Results

« Resource Manager. Provides access to assets including images, cascading style sheets, and scripts. The
Resource Manager pane also includes the Map Editor.

» Results. Displays the results for cross-file operations, Validation, XInclude, Reference Checking, Topic
References, and Key References.

Results .
T 8 By Er e [F X x

Find in result: | [v] A By

Replace with: | [v]

<> | [ E Apply to Apply to highlighted
E4
--|7|_J AboutWorldTimePro.xml { 14 items ) [6
--|_|_J CalculatingElapsedTime.xml { 26 items )
=M CalculatingHoursinMinutesSeconds.xml { 2 items )
~F | Waorld Time Pro...
W Lworld Time Pro...
=" [ CalculatingTime.xml { 12 items )
= L.Calculating time...
: ..\World Time Pro...
WliME. L
..\World Time Pro...
..\World Time Pro... [v]
- l I l . . [>]

Related Links
Working with elements on page 105
Elements are the building-blocks of your documents. They are defined in your DTD or Schema.
Authoring in Normal view is similar to applying styles, whereas Tags On view lets you work with
elements as structural objects. You can insert elements using the Element List, the Insert menu, or
the In-place, look-ahead element list.

Setting attribute values on page 107
You can set attribute values through the Attribute Inspector or through the Edit Properties dialog.
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Toolbars

Results pane on page 92
The Results pane displays the results of cross-file operations, such as the Find in Files feature, and
error-reporting features, such as the Validation Log.

Assets (unsupported) on page 44
You can organize frequently used objects as assets through the Resource Manager. Assets can be
single files, such as images, text, or markup blocks. You can drag and drop assets into your document.

Map Editor on page 138
The Map Editor lets you perform map-specific functions and edit element and map editor properties.
The Map Editor is included in the Resource Manager.

Toolbars

You can show/hide toolbars, create new toolbars, or modify existing ones through View > Toolbars.

Table 1: Standard toolbar

Button Name Description

3 New Page Opens the New dialog or opens a new
document based on the default
template

= Open Opens the Open dialog

= Save Saves the active document

j Save All Saves all open documents

) Find and Replace Opens the Find and Replace dialog

.gqg.} Find Next Finds the next occurrence of the text
string in the Find field of the Find and
Replace dialog

o Check Spelling Opens the Spell Checker

% Cut Removes the selected text or
element(s) to the clipboard

EE Copy Copies the selected text or element(s)
to the clipboard

e Paste Pastes the contents of the clipboard

E) Undo Reverses the last action

& Redo Redoes the last reversed action

| Insert Image Inserts an image element

£= Insert Table Inserts a table element and all required
child elements

= Insert Element Opens the Element List

Resource Manager Opens (or closes) the Resource
Manager

© 2023 JustSystems Canada, Inc.
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Toolbars
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Button

Name

Previous Document

Next Document

Validate Document

Help Contents

Description

Makes the previous document in the
list of open documents the active
document

Makes the next document in the list of
open documents the active document

Validates the active document

Opens the online Help

Table 2: Formatting toolbar

Numbered List

Bulleted List

Decrease Indent

Increase Indent

Cross-Reference

Button Name Description
Graphic ﬂ Style Element Lists the elements.that can be inserted

at the cursor location

B Bold Applies or inserts an element
designated as bold

I Italics Applies or inserts an element
designated as italic

u Underscore Applies or inserts an element
designated as underscore

] Overline Applies or inserts an element
designated as overline

5 Strikethrough Applies or inserts an element

designated as strikethrough (or line-
through)

Inserts an element designated as an
ordered (numbered) list

Inserts an element designated as an
unordered (bulleted) list

Decreases the indent of a list item

Increases the indent of a list item

Opens the Insert Cross-Reference
window

Table 3: Table toolbar

Button

Name

Description

Insert Table
Edit Table Properties

Insert Row Above

Insert Row Below

Delete Row

Opens the Insert Table dialog
Opens the Table Properties dialog

Adds an empty row above the current
row

Adds an empty row below the current
row

Deletes the current row
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Toolbars

Button

Name

Insert Column Left

Insert Column Right

Delete Column
Move Row Up
Move Row Down

Move Column Left

Move Column Right

Merge Cell Right

Merge Cell Left

Merge Cell Up

Merge Cell Down

Split Cell into Rows

Split Cell into Columns

Description

Adds an empty column to the left of the
current column

Adds an empty column to the right of
the current column

Deletes the current column

Moves the current row up one row
Moves the current row down one row
Moves the current column to the left by

one column

Moves the current column to the right
by one column

Merges the current cell with the cell to
the right

Merges the current cell with the cell to
the left

Merges the current cell with the cell
above

Merges the current cell with the cell
below

Splits the current cell into two cells
horizontally

Splits the current cell into two cells
vertically

Table 4: Table Advanced toolbar

Button

Name

Description

Contract Cell from Left

Contract Cell from Right

Contract Cell from Bottom

Contract Cell from Top

Inserts an empty cell to the left of the
active cell

Inserts an empty cell to the right of the
active cell

Inserts an empty cell below the active
cell

Inserts an empty cell above the active
cell

Table 5: Macros toolbar

Button Name Description
¥ Run Current Macro Runs the selected macro
Save Az HTML ﬂ Select Current Macro Shows the selected macro
q Record Macro Records all keystrokes as a new macro

Stop Recording

© 2023 JustSystems Canada, Inc.
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Button Name Description

El Macros Opens the Macros dialog
Table 6: Reviewing toolbar
Button Name Description

@ Track Changes Turns change tracking on (off)

Previous Change

Next Change

Accept Change
Reject Change

Accept or Reject Changes

Revision Mark Options

Goes to and selects the previous
tracked change

Goes to and selects the next tracked
change

Accepts the current change
Rejects the current change

Opens the Accept or Reject Changes
dialog

Shows the Revision Mark Options tab

Table 7: Repository toolbar

Button

Name

Description

= R

ﬁl @l

&

New from Repository Template

Open from Repository
Explore Repository
Check In Document
Check Out Document

Undo Checkout

Document Properties

Displays repository contents
Displays repository contents
Displays a search dialog

Displays repository contents
Displays repository contents

Reverts to previously saved version of
the document

Displays information about the current
document

Table 8: Views toolbar

Button Name Description

<> Plain Text Displays the active document in Plain
Text view

= Tags On Displays the active document in Tags
On view

= Normal Displays the active document in Normal
view

=] Browse Displays the active document in a
browser

@ Attribute Inspector Opens (closes) the Attribute Inspector
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Toolbars

Button

=
-

Name

Insert Element Window

Description

Opens (closes) the Element List

Resource Manager Opens (closes) the Resource Manager
=l Full screen Opens (closes) full-screen mode
Table 9: Whiteboard toolbar
Button Name Description
B Show favorites Displays a selection of favorite
whiteboard commands
1 Customizable This button can be customized in the
Set customizable buttons in
Whiteboard toolbar on page 27 dialog
2 Customizable This button can be customized in the
Set customizable buttons in
Whiteboard toolbar on page 27 dialog
3 Customizable This button can be customized in the
Set customizable buttons in
Whiteboard toolbar on page 27 dialog
Q Customizable This button can be customized in the
Set customizable buttons in
Whiteboard toolbar on page 27 dialog
ne Add to favorites... Displays the Add to Favorites dialog
Fo? Application utilities Displays the Run Macro dialog
Open document Ex Displays the Open Document dialog
A~ Find and execute XMetaL command | Displays a list of all available
commands in XMetaL

Preview toolbar

You use the buttons on the Preview toolbar to display your document in a browser. The default browser is
Microsoft Internet Explorer. The Preview toolbar also has blank buttons that you can associate with other

browsers.

Special Characters and Symbols toolbars

The Special Characters toolbar contains accented letters and other characters that are used in European
languages but that do not have corresponding keys on US English keyboards. The Symbols toolbar contains
special punctuation characters, currency symbols, math symbols, and other symbols. Click a button to insert

a special character or symbol in your document.

Related Links

Character encoding on page 61
XMetal Author supports US-ASCII, ISO-8859-1 (Latin-1), and Unicode™ (UTF-8 or UTF-16) character
encoding. By default, XML files that you create with XMetaL Author use UTF-8 encoding.

Special characters and symbols on page 123
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Display mode

You can use the Special Characters and Symbols toolbars, or the Insert Symbols menu (displayed
by using the keyboard shortcut CTRL + Shift + S), to enter characters and symbols that do not have
corresponding keys on US English keyboards. If your document’s encoding supports it, the characters
and symbols themselves (not the character entities) are saved with your document.

Custom toolbars and menus on page 25
You can create new toolbars and menus and customize existing ones. You can assign buttons and
menus to built-in commands or user-defined macros.

Display mode

You can choose how much space to allocate for displaying your documents. You can also choose to display
your documents in a tabbed interface so that you can easily switch between open documents.

To do this Follow these steps

View a document in full-screen mode Click View > Full Screen

In full-screen mode, the document display area expands to fill the screen, with only the menu bar visible. You
can display other panes and views in full-screen mode.
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Licensing

The licensing feature allows you to register and manage your XMetalL license.

You can view/edit your licensing information by clicking Help > Licensing. The following fields will be displayed:
» License Type - Displays the type of license; either Per-Seat, Concurrent, or Leased Concurrent.
 Licensee - Displays the name of the licensee.

» License Count - Displays the number of seats that apply to this license.
« Maintenance End - Displays the date when the maintenance contract for this license expires.

Activating XMetalL Author

Activating XMetalL Author is required in order for the software to be fully licensed. The license information
required for activation is provided by a license file, or by a licensing server at your company.

When XMetal is started without a full license, you will be prompted to activate the software or continue your

" L= |

é XMetal

If you have an XMetal license file, you can activate your
software now

Trial Period ended T

Help Exit

trial: o

« Activate - Allows you to insert a license file. Choose this option if you have been supplied with a license
file. Possible names for the license file include XMEE. | i ¢, XMES. |'i ¢ and XMLS. | i ¢. When the license
is verified, you are ready to use the software.

-
=/ Note: If you have a license for a version of XMetaL earlier than 9.0, you will need to contact your
system administrator or http://xmetal.com/support for an updated XMetalL Author license file.

« Continue Trial - Allows you to continue with the trial version of XMetaL. The trial lasts 30 days from the

time of installation.
» Exit - closes XMetal.
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http://xmetal.com/support

Removing XMetalL Author License

Removing XMetalL Author License

Removing XMetaL Author from a certain machine and will allow you to use the license on another machine.
Concurrent licenses are automatically returned upon exit of XMetal Author, leaving the local copy of XMetalL

Author deactivated.

1. Click Help > Licensing
2. Click Remove License.

3. Click Ok when the confirmation window pops up.
A dialog will appear asking you to activate the software; you may choose to activate or to exit the program.

=

= Note: XMetalL Author will prompt you to save your work upon exit.

Access Key

An access key, if required by your system administrator, allows you to use XMetalL Author in Concurrent or
Leased Concurrent mode.

An access key may be required to receive a concurrent license. If you do not know the access key, contact
your system administrator.
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Customizing the user interface

You can customize the user interface to give you quick access to tasks and assets. You can make your
changes available to all users or reserve them for your use only. Likewise, your changes can apply only to
documents that use a specific DTD or Schema, or to all documents.

Related Links

Specify tag and tag text colors on page 12

Spell checker options on page 75
You can specify Spell Checker options through Tools > Spell Checker. Your settings are applied
the next time you open the spell checker.

Language settings on page 83
You can choose a language for the current file or set it as the default language for the spell checker
and thesaurus. You can also add and remove languages.

Thesaurus options on page 85
You can specify thesaurus options through Tools > Thesaurus. Your settings are applied the next
time you open the thesaurus.

XMetal customizations on page 103
Formatting and authoring functionality are provided by an XMetalL customization. The basis for an
XMetalL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetal Customization
Guide.

Options on page 49
You can set options through the Tools menu.

Custom toolbars and menus

You can create new toolbars and menus and customize existing ones. You can assign buttons and menus
to built-in commands or user-defined macros.

To do this Follow these steps

Create toolbars and menus for all DTDs and Schemas Perform the customization steps when no document is open

Create toolbars and menus for a specific DTD or Schema | Perform the customization steps when a document that

uses that DTD or Schema is the active document

Toolbars are stored in the following files:

Global toolbars for the current user only. YAPPDATA% Sof t Quad\ XMet aL\ <ver si on>\defaul t. t br
contains toolbars available to the current user for all documents being edited. Toolbars in this file take
precedence over any toolbars of the same name in the above file.

DTD-specific toolbars for all users. Toolbars available to all users for any document based on the DTD
or Schema are contained beside the file location of the .dtd/.xsd OR in a fallback location under

..\ Aut hor\ Rul es\ <dt dname>. t br.

DTD-specific toolbars for current user only..

Y%APPDATA% Sof t Quad\ XMet aL\ <ver si on>\ <dt dnane>. t br and a and per-user "gen" folder area
contain toolbars available to the current user for any document based on the DTD or Schema. Toolbars in
this file take precedence over any toolbars of the same name in the above file.
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Create a toolbar

Related Links

XMetal customizations on page 103

Formatting and authoring functionality are provided by an XMetalL customization. The basis for an

XMetalL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetal Customization
Guide.

Create a toolbar

1.

Click View > Toolbars from the main menu.
The Customize dialog opens.

Select the Toolbars tab.

Click New.
The Toolbar Name dialog opens.

Enter a name, and then click OK.
A floating window appears. This is your custom toolbar.

Select the Commands tab, and then drag and drop buttons from the Commands tab to the new toolbar.

-
=/ Tip: To create a separator line between buttons, click and drag the button to the right.

When have completed your new toolbar, close the Customize dialog.

Create a button or menu

26

1.

Click View > Toolbars from the main menu.
The Customize dialog opens.

Select the Commands tab if it is not already selected.

Under Categories, select New Menu.
The new menu appears in the Commands column.

Drag and drop the new menu to the XMetal's main menu bar.

With the Customize dialog open, right-click on the New Menu button.
A customization menu appears.

Customize the menu button as follows:
e Click Button Appearance.
The Button Appearance dialog opens.

1. Select whether the menu button is Text Only, Image Only, or Image and Text.

2. Click New to add a new image or click Edit to edit an existing image in the Edit Button Image
dialog.

3. Inthe Button Text field, enter the name of the menu button if the menu button has text in the label.

« Click Image to change the text-labeled button into an image-labeled button, or both.

& . . .
"2/ Note: If you click Image and you have not set an image to use, the Button Appearance dialog
opens.

* Click Delete to remove the menu button.

Add menu items to the menu as follows:
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Set customizable buttons in Whiteboard toolbar

e Click Start Group.

* In the Customize dialog's Commands tab, select one of the categories other than New Menu.

< From the list of all available commands in the right-side menu, drag and drop the commands you want
to include in the new menu.

8. When you are finished customizing your menu or button, close the Customize dialog.

Set customizable buttons in Whiteboard toolbar

The three customizable buttons ( 192 13 and q“:’«) in the Whiteboard toolbar can be customized for

your favorite macros, third-party applications, and documents. The default XMetaL installation contains
examples of using third party applications such as finding selected text on Google or WiKi, opening an image
in MS Paint and using free web services for translating selected text to and from different languages.

1. Press Shift and click one of the customizable buttons.
The Customize favorites dialog opens.

2. Select the item you want to relate to one of the buttons.
The selected function is displayed in the Title field.

3. Click the button to which you want to relate the function.
The function is now set for the selected button.

4. Click Run Application to test the function in the Title field.

XMetalL Styling Assistant

The XMetal Styling Assistant and the Active Document WY SIWYG environment provide a means to establish
appropriate document view styles within XMetaL. This process is efficient and straightforward, requiring only
fundamental CSS knowledge. Proficient users can create a preliminary version of comprehensive customization,
while regular users can adeptly fine-tune styles to align with their ongoing tasks.

In XMetalL Author, the presentation of XML and SGML documents can be managed through the application
of cascading style sheets (CSS). The CSS file contains selectors and style properties for each element in
your DTD or schema. Conveniently, the XMetal Styling Assistant facilitates effortless modification of these
style rules. These modifications encompass various attributes such as text font family, size, style, weight,
color, decoration, background, alignment, display style, whitespace handling, and more. This functionality
empowers users to add or replace new CSS styles within the context of existing active document customization,
or to create fresh default CSS styles.

XMetaL Styling Assistant includes:

» Create a new CSS selector.

« Add a new style or edit existing styles for the selected CSS selector.

« Find a CSS selector matching to the selected element in active document if it is possible.
« Create a CSS selector matching to the selected element in active document.

« Add and traverse @import selector by:

 selecting CSS file.
« using XMetaL default style.

» Copy, Past, Delete, or Change orders of CSS selectors.
 Edit existing styles in text mode.
* Import styles from customization default CSS or user defined CSS file.
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XMetal Styling Assistant Editor

« Apply and Save CSS style changes to any opened documents with the corresponding customization.
* Reload active document CSS styles.
« Open the selected CSS file with the system default application or the customer's preferred CSS editor.
« Show the location of the selected CSS file in Windows Explorer.

» Generate default CSS styles for active document based on existing CTM rules.

XMetal Styling Assistant Editor

28

Opening XMetal Styling Assistant Editor

To open the XMetal Styling Assistant Editor, you can utilize the XMetalL quick navigation tool for invoking

the

1.
2.
3.
4,

"CSS styling assistant: open" macro:

Ctrl+?

Ctrl+G

Select "CSS styling assistant” command group, and press Enter key
Select "CSS styling assistant: open" macro, and press Enter key

The active document CSS is loaded into the editor.

XMetal Styling Assistant Editor functionality
[ Sort selectors 10
Find: i Edges  IZ Other Extensions
1R SCOMMENT - Margin top: Padding top:
SPROCINS - -
1 SOCOHENT default [ |eefout
= Margin right: Padding right:
3 ¥ |Appendix Title, Preface Title, Artic l:l default  ~ l:l default
Sect1 Title ) :
a > Sect? Title Margin left: Padding left:
Sect3 Title default default
T [ 1 [ ]
ULink, Link Margin bottom: Padding bottom:
.C | wamingbefore (5 [etans) - [ Jdefait v
7P E:ﬁ:gg:before Border style: Border color:
84 Egtte:before default ~ default I:I Custom
e
9 4} Waming, Caution, Note Border width: Float:
Emphasis hd l:l default - none v
Edit / View selected nules
Aricle Title { Preview of selected C55 rule
fort-weight: bold; :
font-family: Tahoma, sans-serif, Ve S R ™
display: block; Reload active document CS5 e I
font-size: 2007%; .. — y
bordertop: medium; Edit in default application
color: #6699CC; - 1 I I
text-align: center; Editunth W I
)margin-buﬂom: 8pt: Show in explorer
Generate default C55 selectors I b e
< : Restore C55 selectors from the session first saved file N
File: |C:\Program Files (xB6)"XMetal 18, ‘. Restore CS5 selectors from the original file L Save |v
() User defined CS5 (®) Customization default CSS

The XMetalL Styling Assistant Editor consists of the following areas:

» Selectors area: Enables you to create, delete, copy, past, sort, choose selectors, and more.
« Style Rule area: Display the style rule for the current selector and allow you to modify it.

« Sample Text area: Apply formatting to the text according to the style rule.

v
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XMetaL Styling Assistant Editor

» Properties area: Enables you to create or edit the style rules in text mode.

Toolbar of Selectors area

#onimage | Description

1
2

10

Create new CSS selector using "Create Empty Rules" dialog.

Create new CSS selector with properties of selected Selector using "Create Rules with current Properties”
dialog.

Delete a selector from the list.

Clicking the delete button by holding the Shift key deletes the selector silently, When the focus
is on the selectors list, the keyboard keys Del and Shift enable the silent deletion of selectors.
Find CSS Selector matching to Active Document Selection.

How to use:

1. Locate a cursor to the Active Document element whose style you want to change.

2. Click on ">" button to result in the highlighting of the corresponding CSS selector within the list of
selectors.

This function finds the selector in editing CSS style and the explicit selector definition only. For
changes to the complex selectors, such as involving inheritance from nested CSS or using
wildcard symbols, you can use an alternative approach. This involves accessing CSS styles
through external text-based editors.

Create CSS Selector matching to Active Document Selection.

How to use:

1. Locate a cursor to the Active Document element whose style you want to set, change, or create.
2. Click on"+" button resulting in automatic creation of a Full XPath selector without launching Selector

Wizard. By holding the Ctrl button, the "+" button automatically creates a simple selector. This
allows users to change styles instantly.
Copy selected CSS selector(s).
Click on "C" button enables the copying of selector(s) from the imported CSS. Holding the Ctrl
key while clicking the Copy button allows to copy all selectors.

Append or insert copied CSS selector(s).

Click on "P" button enables the pasting of selector(s) from the imported CSS. Clicking on the
Paste button appends the selectors. Holding the Shift or Ctrl key facilitates the insertion of
selectors into particular position before or after the currently chosen selector in the list of selectors.
Change the order of the selectors: Move up.

Change the order of the selectors: Move down.

Find the desired text within the selectors list.

Use the "Arrow up/down" buttons to locate subsequent or preceding text.

Click on "</>" button reveals a list of the current element name, attribute names, and their
corresponding values in the Active Document. Once a selection is made, the chosen content is
presented in the "Find:" text box.
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#onimage | Description
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Save options
The Save button drop-down list provides the following options:

« Apply and Save CSS styles as a default action.

 Reload active document CSS.

 Edit in the system default application.

 Edit in the customer's preferred CSS editor.

« Show the location of the selected CSS file in Windows Explorer.

» Generate default CSS styles for active document based on existing CTM rules.
» Restore CSS selectors from the original file:

» Once users modify the Default CSS Customization and save these changes for the 1st time. the assistant
generates a "*.bak" file holding the original state of the Default CSS Customization. This feature simplifies
the process of reverting to the initial Default CSS Customization state.

* Restore CSS selectors from the session first saved file:

* When users make alterations to any CSS files and save those changes for the first time during each
session in utilizing the styling assistant, the assistant generates a "*.bak1" file. This file retains the CSS
state before the first save during each session. This feature allows users to revert to the CSS state prior
to the first save in the ongoing session before closing the XMetalL Styling Assistant Editor dialog.

Note: If the present CSS file is altered using an external editor while the XMetalL Styling Assistant Editor is
open, you will encounter a warning message upon refocusing on the assistant.

"User defined CSS" and "Customization default CSS"
Users can switch between "User defined CSS" and "Customization default CSS" modes.

"Customization default CSS" is developed for specific DTD or schemas. It defines the general default view
styles displayed in both Normal and Tags On views. While XMetaL Developer is a recommended platform
for creating this type of CSS, users may modify, add, or generate their own styles through the XMetaL Styling
Assistant Editor in accordance with specific editing requirements or personal preferences.

If users frequently engage in tasks of changing font family, size, styles, and background/foreground colors
for specific XML elements, along with their layout in the editor view, switching to "User defined CSS" mode
is a conventional approach.

@import selector

In XMetalL Styling Assistant Editor, the @import selectors are supported. Selecting the "User defined CSS"
mode in the XMetalL Styling Assistant Editor results in adding the special @import selector: "@import
url('$CUSTOMIZATION_DEFAULT")" by default.
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Find:

o +W%W % w

n

& D

[] Sort selectors

Para Edges == Other (® Extensions
@import ud('FCUSTOMIZATION DH Font family: Font color;
inherit |:| Custom
Font size: Font weight (bold):
inherit inherit
Font style Font variant {small
inherit inherit
Text align: Text decoration
inherit Mone Overline
Text indent: Inderline Line-throug
Double underline Double ove
inherit
Vertical align: Background color:
default defat [ | custom
Edit / View selected rules
Preview of selected CS55 rule

@import ul(SCUSTOMIZATION_DE

disappear.

< >

You are now creating a new rule to specify the style for this eleme
vou change rules before setting any properties, your new rule will

File:

C:hUsershithelp \AppData“Roaming 5ot Quad ' XMetal \18.0MC55-5hvles joumalist\joumalist .css

| L

@ |ser defined C55

() Customization defautt CS5

The "File text box" contains the full path to the editing CSS file.

Double clicking on the @import selector imports the CSS file from the default document customization and
displays all selectors and CSS styles as follows.
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[] Sort selectors
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Edit / View selected rules

SCOMMENT { Preview of selected C55 rule
display: inline;
color: #500000; . : : : .
white-space: pre; This is approximately what this element will look like. There v

fontfamily: sans-senf;
background-calar: HEOEDED:

text-align: left;
L4 i
File: |C:XPn::gram Files (x86"¥Metal 18.00AuthortDisplayjoumnalist css | | € | [Save |v|
(®) User defined C55 () Customization default C55

| Select parent C55 i

The "<<" button adjacent to the "File text box" becomes active, enabling you to navigate back to the parent
Css.

To insert the @import selector, several other methods are available:
« Select a Custom-type selector in the "Create Empty Rules" or "Create Rules with current Properties" dialog:

» Choose the option of browsing desired CSS file in Insert button.
« Choose the option of "@import: XMetalL default style” in Insert button.

CSS Styling Assistant Macros

Within the "CSS styling assistant” command group, there are seven distinct CSS styling assistant macros.
To access the list of command groups, press Ctrl+? followed by Ctrl+G. After selecting the "CSS styling
assistant" group and pressing Enter key, all the macros within the group will be displayed.

* <MACRO name="CSS styling assistant: open" hide="false" lang="JScript" desc="Edit Active Document
CSS styles.">

* <MACRO name="CSS styling assistant: close" hide="false" lang="JScript" desc="Close Active Document
CSS styling assistant.">
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* <MACRO name="CSS styling assistant: refresh content" hide="false" lang="JScript" desc="Reload Active
Document CSS styles into the styling assistant.">

* <MACRO name="CSS styling assistant: show selector" hide="false" lang="JScript" desc="Find and show
CSS selector corresponding to current Active Document XML tag.">

 <MACRO name="CSS styling assistant: create custom selector wizard" hide="false" lang="JScript"
desc="Create CSS selector corresponding to current Active Document XML tag.">

« <MACRO name="CSS styling assistant: create simple selector" hide="false" lang="JScript" desc="Create
simple CSS selector corresponding to current Active Document XML tag.">

* <MACRO name="CSS styling assistant: create full XPath selector" hide="false" lang="JScript" desc="Create
CSS selector containing all parent elements and corresponding to current Active Document XML tag.">

Create a selector

You can create a blank selector or copy style rules from an existing selector.

How to create a selector

1. Inthe XMetaL Styling Assistant Editor, do one of the followings to invoke Create Empty Rules window:

» Click I Create new CSS selector.

* In the Selectors list, click the name of the selector whose style rules you want to copy. Click * Create
new CSS selector with properties of selected Selector.

2. In the Create Empty Rules dialog,

Create Empty Rules

Choose type of selector to create

() Simple

0 Peeudo (before)

Pzeudo Hement

Select Element:

Postoode
ProgramListing
PubDate
Sectl

Sect?

Sect3

Sectd
Seedlso
Segflsoltem
Source
State

do the followings:

() child
i) Attribute

) Sibling () Descendant
) Custom

C

[_)Class (

sample: Title:before { color: blue }

Pseudo elements enhance C55 styling capabilities. In the sample above, blue color
iz applied to content inserted before the Title element. The “content” property,
in conjunction with this pseudo-element, spedfies what is inserted,

Pseudo selector
0 :before
() :after
() sfirst-child

a. Choose a type of selector.

b. Locate the cursor on the Active Document element for which you intent to create a style. Then, either
click on the "</>" button located next to the "Select Element:" to select current active document

Selectaors to be created:

Sectl:before

K
it
L

B 2dd as a grouped selectori

Cancel
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element, or select the element's name or XMetaL specific selector directly from the "Select Element”
list.

c. Click on the ">" button to add the specified selector to the list of selectors being created.

d. If you want to create a single style rule to apply to all selectors in the list of selectors being created,
click the Add as a grouped selector option.

Note:

« For all types of selectors, the CSS styling wizard allows synchronizing the element selection in Active
Document with the selection in "Select Element" list. Use the "</>" button in the wizard to synchronize.

« New selectors must have style rules associated with them and be saved before the cascading style sheet
editor is closed.

Type of selectors

Simple selectors

The following example causes all Title elements to appear in blue:

Title {color:blue;}

Pseudo selectors

The following rule causes the content inserted before the Title element to appear in blue:
Title:before {col or:blue;}

Child selectors

The following rule applies to all Title elements that have Book as a parent:
Book>Title {col or: bl ue;}

Attribute selectors

The wizard allows the synchronization of element selection with a designated attribute value in the Active
Document, using the "Attribute" selector type.

The following rule causes all Emphasis elements that have attribute "role" with value "bold" to appear in blue:
Enphasi s[rol e="bol d"] {col or: bl ue;}

Sibling selectors

The following rule specifies the color blue for all Title elements that are preceded by Book element:

Book + Title {col or:blue;}

Class selectors

The wizard allows the synchronization of element selection with a designated @class attribute value in the
Active Document, using the "Class" selector type.

The following rule causes all Title elements that have attribute "class" with value "news" to appear in red:
Title.news {color:red;}
Descendant selectors

The following rule causes all Title elements that are within Book elements to appear in blue:

Book Title {color: blue;}
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Custom selector
Under the "Custom" selector type, the "Insert" button presents three options:

» Browse CSS file to import CSS styles.
* Import XMetalL default CSS styles.
» Generate a full path selector to the selected element in Active Document.

After clicking the "Insert" button, the "Insert text box" automatically displays the full path to the selected
element in the Active Document. In order to modify the full path, you can utilize the "+" button in the "Create
Empty Rules" dialog after selecting the element name in the "Select Element" list. This button enables you
to construct a custom selector string, Alternatively, you can directly edit the element path.

Create Empty Rules

Choose type of selector to oreate

() simple () Child () sibling i) Descendant
() Pseudo (:before) () Attribute () Class (®) Custom
Custom Selector Book > Title + Para { color: blue }

Edit @ custom selector, import statment or namespace dedaration:
[:.ﬁ.rtide :=-5E|:t1:=-F‘araJ | | Insert |V|

| SelectElement: |<f= @import: browse...

Sect2 A ) .
Sect3 @import: ¥Metal deafult style

Sectd Active document selection element (deafault
| |Seedlso
| |Seealsoltem »
| Source
State
| |Street ﬁ
' a1
I Subscript
Superscript W [ ]add as a grouped selector

| oK Cancel
|

When you click the "</>" button adjacent to the "Insert" button, a list will appear containing combinations of
the current element name, attribute name, and corresponding value from the active document. By selecting
an option from this list, you can insert various combinations of the element name, attribute name, and attribute
value into the "Insert text box".
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Create Empty Rules

Choose type of selector to create

() simple () Child

() Pseudo (:before) () Attribute

Custom Selector

Edit & custom selector, import statment or namespace dedaration:

() sibling () Descendant
() Class (®) Custom

Book > Title + Para { color: blue }

| Para[ld="p17]

| == Insert |v

Select Element: |</=

ItemizedList ~
JobTitle +
LastModDate
Link

ListTtem
LiteralLayout
Location
Mote
OrderedList

DrENamE
W

Dhnna

Article>5ect1>Para

> Para
[ld="p1"]
X
i
4

[ ]Add as a grouped selector

o4 Cancel

Creating the new selector "Para[ld="p1"]" and setting the text font color to be blue in XMetalL Styling Assistant
Editor results in the following style rule. This causes the element "Para" with @Id="p1" to appear in blue:

Para[l d="pl1l"] {color: blue;}

Note: For a description of selector syntax, see the CSS specifications on the World Wide Web Consortium

website at www.w3c.org.

XMetaL specific selectors

XMetal -specific selectors, which let you take advantage of specific XMetaL functionality. In the list of available
selectors, these appear first unless you change the order.

Table 10: XMetalL-specific selectors

Name Description

$DOCUMENT Applies styles to an entire document. All other selectors
inherit the styles set for this selector unless different styles
are set specifically for subordinate selectors.

$MARKSEC Applies styles to any marked sections in SGML documents
or CDATA sections in XML documents.

$COMMENT Applies styles to comments within an XML or SMGL
document.

$PROCINS Applies styles to processing instructions within an XML or

SGML document.
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Examples of XMetalL Styling Assistant Usage

Styling processing instructions
You can style processing instructions using the $SPROCINS keyword and the following qualifier names:

XM pi -target
Xm pi - dat a

Examples of styling processing instructions

The processing instruction with "xm-replace_text" as "xm-pi-target" is used to specify <MiniTemplate> for

each element in the CTM file. For example,
<Tenpl at e>
<Name>Par a</ Name>
<M ni Tenpl at e>
<! [ CDATA[ <Par a><?xm r epl ace_t ext Par agraph?></Para>]] >

</ M ni Tenpl at e>
</ Tenpl at e>

When the element is inserted, the value of "xm-pi-data" is displayed as a replacement text. In the above
example, inserting <Para> element shows "Paragraph”. The replacement text can be styled using $PROCINS
as the following examples.

The following rule styles all replacement text Pls in green color:

$PROCI NS[ xm pi -t arget ="xmrepl ace_text"] {color: green;}

The following rule colors all PIs with "Paragraph” as "xm-pi-data" value using blue text:

$PROCI NS[ xm pi - dat a="Par agr aph"] {col or: bl ue}

The following rule styles all occurrences of Pls with "xm-replace_text" as "xm-pi-target" and "Paragraph" as
"xm-pi-data" in red color:

$PROCI NS[ xm pi -t arget ="xmrepl ace_text"] [ xm pi - dat a=" Par agraph"] {color: red;}

Examples of XMetalL Styling Assistant Usage

For users often involved in tasks such as modifying font family, size, styles, and background/foreground colors
for specific XML elements, along with arranging them in the editor view, setting to the "User Defined CSS"
mode in the XMetalL Styling Assistant Editor is a customary method. In this mode, by default, the @import
statement to the default customization is added.

Scenario 1:

1. Move selection between Active Document element and XMetaL Styling Assistant to find and create
selectors using the ">" and "+" toolbar buttons and the Save button, along with the CSS styles wizard.

2. Set styles according to your preferences.
Scenario 2:

1. Remove all styles and @import statements.
2. Select "Generate default CSS" option in the "Save" button.
3. Edit default customization styles according to your preferences.

Scenario 3:

1. Double click on @import default styles statement .
2. Copy all styles.
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3. Return back to the parent CSS using the "<<" button and delete @import default statement.
4. Append copied selectors.
5. Edit default customization styles according to your preferences.

Scenario 4:
This scenario allows to have both default customization styles and overwritten styles.

Remove all styles and @import statements.
Move selection between Active Document element and CSS styles wizard using the "+" button.
Create your own styles customization.

Open "Create Empty Rules" dialog using the * button.
Select a Custom-type selector and select "Import XMetal default CSS" option in the "Insert" options.

a bk Wb
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You can edit the properties of your style rules through the XMetal Styling Assistant Editor. The Properties
area lets you select options to set properties, or you can type properties directly in the Style Rule area. By
default, many properties inherit their value from parent and ancestor elements.

The XMetaL Styling Assistant Editor's Properties Area comprises four tabs, each displaying the style properties
applicable within XMetaL. To configure these properties for a given selector, users can choose the relevant
selector within the Selectors area, access the corresponding tab, and proceed to adjust the property values
as needed.

Table 11: Properties

Click this tab: To edit:

Text Fonts, text alignment, and indent

Edges Margin, padding, and borders

Other Miscellaneous properties, including classification,

whitespace, and counters

Extensions XMetal-specific properties, including indent, prefix, and
view settings

You can also add other properties by editing the text in the Style Rule area. However, these properties may
not be visible in XMetalL.

For descriptions of CSS properties see the World Wide Web Consortium website at www.w3c.org.
Extensions properties

The Extensions tab in the XMetal Styling Assistant Editor contains XMetal -specific properties. The properties
on this tab are not part of the CSS specifications, and can be viewed only in XMetalL.

Left indent

Use this property to display the element(s) indicated at a set distance from the left margin, regardless of the
position of any ancestor element.

Prefix options

Use this property to display prefix text, the attributes of an element, or the parameters and parameter entities
of a marked section (in Tags On view only). You can set the following prefix options:
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Using counters and auto-numbering

» To set a rule to display prefix text, type the desired text.

 To set a rule to display all attributes with non-null values for the element(s) to which the style applies, type
[Yattribute-list;].

 To set a rule to display the value of a specific attribute for the element(s) to which the style applies, type
[%attribute ATTRI BNAME; ], where ATTRIBNAME is the name of the attribute whose value you want
to display.

« If you are creating a display rule for marked sections, you can choose to display marked-section parameters
and parameter entities by typing [ %par aneters;].

Using counters and auto-numbering
A counter is an element prefix that is incremented for each successive occurrence of that element. You can
create counters in your document using pseudo-selectors and counter properties.

You can add simple or multi-level counters to elements in your document. For example, chapters in a document
may be numbered 1, 2, 3, etc. and subsections of a chapter may be numbered 1.1, 1.2, ..., 2.1, 2.2, ..., etc.
A counter can be initialized to start at a specified value and various numbering styles are available.

Counters are displayed in : bef or e and : af t er generated text by using the count er and count ers
functions. They are configured using the count er - i ncr enent and count er - r eset properties under the
Other tab.

Simple counter

The following rule associates a counter with the Sect 1 element and gives this counter
the name ‘section’, so that it can be referred to elsewhere in the style sheet.

Sect1 {
counter-increnent: sectionl;

}

Displaying a counter

The following rule displays the counter at the start of the Sect 1 element, but it is more
common to display the counter before an element’s title (if there is one):

This rule displays the counter at the start of the Sect 1 element, but it is more common to
display the counter before an element's title (if there is one):

Sect 1>Titl e: before {
content: counter(sectionl);

}

You can include text before or after the counter. For example, the following rule displays
1., 2., ... before the titles:

Sect1>Titl e: before {
content: counter(sectionl)

}

Resetting the numbering
The following rules reset the number for each new list:

I'tem zedLi st {
counter-reset: |i;
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}
Listltem{
counter-increnent: |i;

Li stltem before {
content: counter(li) ". ";

}

Initializing counters
The following rule resets the counter to 5:

Sect 1l {
counter-increment: sectionl;
counter-reset: section2 5;

}

Multi-level counters

The following rules define two counters, sectionl and section2. The count er - r eset
property in the Sect 1 rule means reset the counter called section2 to zero whenever a

Sect 1 element is encountered.

Sect1 {
counter-increnent: sectionl;
counter-reset: section2;

}
Sect1>Titl e: before {
content: counter(sectionl) ". ";

}
Sect 2 {
counter-increnent: section2;

}
Sect 2>Titl e: before {
content: counter(sectionl)

}

counter(section2) ". ";

Numbering styles

The following rules specify upper - al pha and | ower - r orman style counters:

Sect 1>Titl e: before {
content: counter(sectionl, upper-alpha) ". ";

}
Sect 2>Titl e: before {
content: counter(sectionl, upper-al pha)

counter (section2, | ower-roman) ". ";

View support for properties and selectors
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The tables below indicate XMetal Author display support for CSS properties and selectors.

Table 12: Assigning property values, cascading, inheritance

Name

XMetal Author Normal
View

‘@import’ rule X
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Name

‘inherit’ value

XMetalL Author Normal
View

X

Table 13: Font properties

Name

XMetaL Author Normal
View

font

font-family

font-style

font-variant

font-weight

font-size

X | X | X| X| X| X

Table 14: Color and background properties

Name XMetal Author Normal
View

background X

background-attachment -

background-color X

background-image

background-position

background-repeat

Table 15: Text properties

Name XMetaL Author Normal
View

color X

text-indent X

text-align X

text-decoration

X (except double-overline
and double-underline)

letter-spacing

word-spacing

text-transform

vertical-align

sub and super only

line-height
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Table 16: Box properties

Name

XMetalL Author Normal
View

border, border-top, border-
right, border-bottom,
border-left

X

border-color

X (only when set to the same
value for all sides)

border-top-color, border-
right-color, border-bottom-
color, border-left-color

X (only when set to the same
value for all sides)

border-style

border-top-style, border-
right-style, border-bottom-
style, border-left-style

border-width

X (only when border-xxx-
width are set to the same
value)

border-top-width, border-
right-width, border-bottom-
width, border-left-width

X (only when set to the same
value)

clear

float

height

width

margin

margin-top, margin-right,
margin-bottom, margin-left

padding

padding-top, padding-right,

padding-bottom, padding-left

Table 17: Classification properties

Name XMetal Author Normal
View

white-space X

display X

list-style X

list-style-type X

list-style-position

list-style-image
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Table 18: Generated content, auto-numbering, and list properties

Name

XMetalL Author Normal
View

content: <string>

X

content: <uri>

content: <counter>

content: attr(X)

counter-increment

counter-reset

X | X X | X

Table 19: Positioning properties

Name

XMetalL Author Normal
View

position

top

right

bottom

left

width

height

clip

overflow

z-index

visibility

Table 20: Other properties

Name

XMetalL Author Normal
View

@media

direction

unicode-bidi

x| X

min-width

max-width

@page

page-break-before, page-
break-after

page-break-inside

orphans

widows

border-collapse
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Assets (unsupported)

Name

border-spacing
caption-side
table-layout
empty-cells
cursor

outline
outline-width
outline-style

outline-color

XMetal Author Normal
View

Table 21: Selectors

Type

XMetalL Author Normal
View

Grouping

Universal Selectors

Type Selectors
Descendant Selectors
Child Selectors

Adjacent Sibling Selectors
Attribute Selectors

Class Selectors

ID Selectors

Pseudo-Classes

Pseudo-Elements

X | X | X| X| X| X| X| X

first-child only

:before and :after only

44

You can organize frequently used objects as assets through the Resource Manager. Assets can be single
files, such as images, text, or markup blocks. You can drag and drop assets into your document.

To do this

Follow these steps

Create an asset folder

Add an asset to an asset folder

In the Resource Manager, click the Assets tab. Right-click
the My Assets folder, and select New Folder. Specify a
name and asset type.

Click the Desktop tab, select a file, drag it onto the Assets
tab, and drop it in an asset folder.

The Resource Manager contains the Assets tab and the Desktop tab.

The Assets tab contains the following folders:
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» Customizable Asset Templates. A set of templates that can be used to create your own asset folders.
An asset template is displayed when you click on a folder.

« Journalist DTD. A set of sample assets to be used with the Journalist DTD.

« My Assets. A folder for organizing your assets.

The Desktop tab gives you access to the files on your computer.

You can create your own asset folders to organize and categorize objects. When you create an asset folder,
you must specify an asset type. You create an asset by dropping a file from your computer into an asset
folder.

The types of assets that you can create in My Assets are defined by asset templates, which are located in
..\ XMet aL <versi on>\ Aut hor\ Asset Tenpl at es. You can add more templates to this folder, for
example, by copying them from . . \ XMet aL <ver si on>\ Aut hor\ Asset s\ Cust oni zabl e Asset
Tenpl at es.

& )
"2/ Note: You may need to customize some of these templates for your DTD or Schema.

-
=/ Tip: You can drag and drop images, text, or markup blocks from your documents into asset folders.

Related Links

XMetal customizations on page 103
Formatting and authoring functionality are provided by an XMetalL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetal Customization
Guide.

Images on page 110
You can insert images into your documents if your XMetalL customization recognizes elements in
your DTD or Schema as image elements, or if you are using DITA.

Macros

A macro is a sequence of operations that can be run as a unit. Macros can be associated with a shortcut key,
toolbar button, or menu item. They are useful when you need to repeatedly execute a task that does not have
a built-in shortcut key or command.

To do this Follow these steps

Run a macro Click Tools > Macros. Then select a macro and click Run.

& - . .
2 Tip: You may want to create keyboard shortcuts for frequently used macros, or associate them with

toolbar buttons or menu items.

DTD-specific macros are available when you edit a document using the associated DTD or Schema; global
macros are available to all documents and when no documents are open.

Macros are stored in the following files:

» Global macros for all users.. .\ XMet aL <ver si on>\ Aut hor\ Macr os\ xnet al . ncr contains macros
available to all users for all documents. This is the default macro file.
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Macro design guidelines

* Global macros for the current user only. “%APPDATA% Sof t Quad\ XMet aL\ <ver si on>\ xnet al . ncr
contains macros available to the current user for all documents being edited. Macros in this file take
precedence over any macros of the same name in the above file.

» DTD-specific macros for all users. ..\ XMet aL <ver si on>\ Aut hor\ Macr os\ <dt dnane>. ntr
contains macros available to all users for any document based on the DTD or Schema.

« DTD-specific macros for current user only.

Y%APPDATA% Sof t Quad\ XMet aL\ <ver si on>\ <dt dnane>. ntr contains macros available to the current
user for any document based on the DTD or Schema. Macros in this file take precedence over any macros
of the same name in the above file.

Macmo name Shortout key Source Userip) %

N nsert Mhatract jeumalat Al Users — .
1 Ingent Appandu joumiabat Bl Usern {. }
.[2 Insert Authar joumalist All isers e
@ bsert Biblioltam joumalkist Al Users
ALY Insest Chation jourmiakist Al Ugere

1D Insert Copyright joumalst Al Usern

Er Toggle Emphass ioumakst Al Lsers

B Toggle Strong jourmsist Al Users

TTToggle TT jeumalist Al Users L=

U Toggle Undemcore joumalst Al sera [ Cancel ]
ﬂ Insert Figure joumabst Al Users

[ brsert Graphie joumakst Al sers = | Huln |

Related Links

XMetal customizations on page 103
Formatting and authoring functionality are provided by an XMetalL customization. The basis for an
XMetalL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetal Customization
Guide.

Macro design guidelines

46

You are advised to observe some guidelines when designing macros.

First, macros should be self-contained, that is, they must not depend on user input during execution. (Therefore,
some actions cannot be included in a macro.)

If a macro involves any of the commands that open dialog boxes, that action should be completed somewhere
in the macro. (Commands or buttons that open dialog boxes have an ellipsis (...) after the command or button
name.) For example, you can create a macro that inserts a particular element, but you cannot create a macro
that simply displays the Insert Element dialog.

Mouse clicks in the document pane are ignored during macro recording. The first time you try to use the
mouse to change the selection, you will hear an alert. The second time, a message appears saying that you
should use the cursor (arrow) keys to change the selection.

Not all commands can be recorded in a macro. A macro that was recorded in Normal or Tags On view can
usually be played back in the other view. Macros recorded in Plain Text view are less likely to work in the
other views.

In addition to the above restrictions, the following actions cannot be recorded in a macro:
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Record a macro

« Actions that make a different document the active document (for example, drag and drop between documents)

« Setting table properties
Spell checking operations
* Most commands in the File and View menus

Record a macro
e Note: Recording is limited to keyboard actions only.

Click Tools > Record New Macro.

Click Tools > Stop Recording.

Select an option from the Create this macro for list.
Type a name.

(Optional) Do any combination of the following:

o gk whPRE

« Specify a shortcut key combination to associate with the macro
« Specify an image to associate with the macro

Create a keyboard shortcut

1. Click Tools > Macros.
2. Select a macro.
3. Choose a shortcut key combination.

Macro name Shortout key Source Uiseria) M

Ml insert Abstract joumakist Al Usars

M ingert Appendx oumalist Al Usars
& et futhor joamalist All Users

Q nsart Bblckem joumalis! A s
|L Insart Cration joumizkst Al Users

© Insert Copynight joumalist Al Users

Fa Toggle Emphasis joumalist Al U

B Taggle Srong poumialist Al Uy

TT Topga TT joumialiat Al Lsars
To;g-:_fndmcw oumalist Al Ugers Cancel

i Inset Figuee joumislist Al Usars

[Z] inset Graphic: joumialist Al Uz
Maero name: | Irsedt Abetract

= S
Sostker [lod Ol sk o v ~fenoose mage |

Associate a macro with a toolbar button

1. Click View > Toolbars and select the Buttons tab.

Perform the sequence of actions that you want the macro to execute.

2. Select Application Macros or <dtdname> Macros (where dtdname is the name of the DTD or Schema

for the current document).
3. Select a macro.
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Associate a macro with a menu item

4. (Optional) Do any combination of the following:

« Choose an image to associate with the macro
« Type the text you want to appear as the button tooltip
« Type the text you want to appear in the status bar while the macro is running

Associate a macro with a menu item

1. Click View > Toolbars and select the Menus tab.
2. Select a menu to which you want to add your new command and click Add Menu Item.
3. From the Macros list, select a macro.

Toolbar and Menu Customization

Tocbars | Buttors | Menus

4. Type a name in the Caption text box.

8 - . .
"2 Tip: Type the ‘& characterimmediately before the letter that you want to use as the keyboard shortcut
(the underlined letter).

5. (Optional) Do any combination of the following:

« Type the text you want to appear in the status bar while the macro is running
* Select the Begin Group option to create a separator line above the command in the menu

XMetalL API for providing asynchronous operations

The API enables you to run XMetal macros when XMetal enters an idle state or when triggered by external
events, e.g., "specific time elapsed”, specific file(s) changed or specific application terminated.

Here are some scenarios that an XMetal customization developer can achieve via macro scripts:

1. Selectaword in an open document - specify the file path that receives proposed alternatives for a selected
word - run third party application passing word and file path as parameters - continue editing in XMetalL
- after application completed or file changed events - run macro that moves selection to selected word -
reads file with alternatives - show alternatives to user.

2. XMetal monitors the status of specific files in folders. Changing specific files via third party applications
triggers running the XMetaL macro asynchronously. The XMetalL macro script reads the contents of the
file that triggered the event.

* RunMacroOnldle - runs the XMetalL macro script asynchronously after XMetalL has entered to an idle
state. Optional parameters specify additional delay time and a VARIANT-type parameter that can be passed
to the macro.

« RunAfterProcessDone - runs the XMetal macro script asynchronously after a specific Windows process
was terminated and XMetalL has entered to an idle state. Optional parameters specify a VARIANT-type
parameter that can be passed to the macro.
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Options

« AddFileChangeMacro - runs the XMetal macro script asynchronously after predefined file(s) were changed
and XMetal has entered to an idle state. Optional parameters specify the full file path or pattern and a
VARIANT-type parameter that can be passed to the macro. XMetal provides additional default parameters
containing the full path of the file that triggered the event.

« Additional XMetaL APIs "IsProcessRunning", "TerminateProcessEx", "RunAfterProcessDone2",
"IsFileChangeMacro", "RemoveFileChangeMacro" allow you to maintain a customization based on an

asynchronous event.

Options

You can set options through the Tools menu.

Settings are stored in an XMetaL configuration file in the following locations:

« Global settings: . .\ XMet aL <ver si on>\ Aut hor\ xnet al . i ni contains settings that are available to

all users.

» Settings for the current user only: contains settings for the current user only. XMetalL Author makes
changes only to this file. Settings in this file take precedence over any settings of the same name in the

above file.

Y%APPDATA% Sof t Quad\ XMet aL\ <ver si on>\ XMet aL. i ni

Table 22: General options

Option

Description

Current user
Location to temporarily store remote files
Show tag tips

Restore last open documents

Restore selection in open document

Check spelling while typing

Replace words from my word list while typing

Identifies documents by
username and initials

Specifies a location to
temporarily store remote files

Displays attributes in a tooltip

Re-opens documents that
were open when XMetalL
Author was last closed

Moves a selection to the
selected point before the
document was closed.

@ . .
““ Note: Changing this
option requires
restarting XMetalL.

Automatically checks spelling
as you type
Automatically replaces

misspelled words with words
from your word list.
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50

Option

Enable bi-directional text support

Enable Workbench

Enable AutoComplete for cell values

Enable AutoComplete for attribute values

Description

Allows users to create text in
languages that are right to
left

e Note: A system
restart is required for
changes to take
effect.

e Note: Turning off the
'Check spelling while
typing' option is
recommended when
bi-directional text is
enabled.

Allows users to use
Workbench feature in
Resource Manager

G/' Note: A system
restart is required for
changes to take
effect.

Allows users to complete cell
values automatically

Allows users to complete
attribute values automatically

Table 23: View options

Option

Description

Open new documents in
Tag icons

Show inline images
Show comments

Show structure view by default

Specifies a default view for opening documents

Provides formatting information for tags in Tags On view

Displays inline images

Displays comments in Tags On view

Displays the structure view when opening a document

Table 24: Plain Text View options

Option

Description

Font
Syntax Coloring
Tab

Specifies a text font

Specifies colors for markup and scripts

Determines how tab characters are handled
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Option
Word Wrap

Line numbering

Description

Specifies how to display lines that are longer than the width
of the document pane

Displays line numbers

Table 25: File options

Automatic Saves

End of Line

Option Description

New Specifies a template for files created through the New Page
button

Save As Specifies a default extension when saving new documents

Backups Saves backup copies of your files

File Menu Specifies the number of recently used documents to display

Specifies the number of changes or minutes after which
your document will be saved automatically

Specifies line ending options for different operating systems

Table 26: Change Tracking options

Option

Description

Inserted text

Deleted text

Specifies format, color, and preview options for inserted
text

Specifies format, color, and preview options for deleted text

Table 27: Windows and Tabs options

Option

Description

Visual theme

Show "Close" button on the active tab

Show pop-up menu of tabbed windows

Animate "auto-hide" docking panes

Specifies the displayed
Windows theme

Displays a "close" button for
file that is active

Displays a pop-up menu of
tabbed windows

Turns animations on when
these panes are unpinned

Table 28: Symbols options

Option

Description

Insert symbol using unicode hex

Delete symbol

Up / Down

Adds a symbol mapped to the entered unicode hex to the
Insert Symbols menu that can be opened by typing the
keyboard shortcut CTRL + Shift +S.

Deletes a symbol from the Insert Symbols menu

Moves a selected symbol up or down as displayed in the
Insert Symbols menu

Related Links

Spell checker options on page 75

© 2023 JustSystems Canada, Inc. 51



Options

You can specify Spell Checker options through Tools > Spell Checker. Your settings are applied
the next time you open the spell checker.

Thesaurus options on page 85
You can specify thesaurus options through Tools > Thesaurus. Your settings are applied the next
time you open the thesaurus.

XMetal customizations on page 103
Formatting and authoring functionality are provided by an XMetalL customization. The basis for an
XMetal customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetal Customization
Guide.

DITA options on page 198
You can control DITA behaviors using the settings in the DITA Options dialog box. Options can be
set for all specializations or on a per-specialization basis.
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Managing documents

This section contains information about managing documents such as creating, opening, printing and saving
documents, creating well-formed XML documents, and working with a repository.

Creating documents

You can create a document from a template, create a blank XML or SGML document, or create a blank,
well-formed XML document. You can set file options, including a default template, filename extensions, and
autosave intervals through Tools > Options.

To do this Follow these steps
Create a document from a template Click File > New. Then click a tab and choose a template.
Create a blank XML or SGML document Click File > New. In the General tab, select Blank XML

Document or Blank SGML Document. Then choose a
DTD, Schema, or Rules file.

Create a blank, well-formed XML document Click File > New. In the General tab, select Blank Well-
Formed XML Document.

The appearance of your new document and much of the authoring functionality is determined by an XMetalL
customization. When you create a document that is based on a DTD or Schema that does not have a
customization, the following files are created in the same folder as your DTD or Schema:

* Rules file - a Rules file is a DTD or Schema that has been compiled into a binary format. Rules files have
an .rlx extension for XML files, an .rls extension for SGML files, and an .rld extension for Schemas.

« Style sheets for the document view and structure view (.css) - styling is based on element names. XMetalL
Author recognizes many elements defined in XHTML, DocBook, and the Journalist DTD.

» Customization file (.ctm) - this file contains authoring behaviors that are based on the elements and attributes
in your DTD or Schema (for example, some keyboard shortcuts, Enter key behavior, and mini-templates).

CEEE———— x|
General | DITA Glossary | DITA Leaming | DITA Map | DITA Topic | Joumaist | Meeting |

& & @

Blank SGML  Blank Blarik XML
Document Well-Foem Document
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Templates

Related Links

Options on page 49
You can set options through the Tools menu.

XMetal customizations on page 103
Formatting and authoring functionality are provided by an XMetalL customization. The basis for an
XMetal customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetal Customization
Guide.

Templates

Templates let you create new documents that use a particular DTD or Schema. They can also provide a
document outline and text that help you in the authoring process.

You should create at least one template for each DTD or Schema. In many cases, you can use the same
template to create either an XML or an SGML document. However, if your DTD was designed for SGML
documents, it may contain features that are not supported in XML.

Templates are stored in the following folder:. . \ XMet aL <ver si on>\ Aut hor\ Tenpl at e.You can organize
your templates in sub-folders. Sub-folders appear as tabs when you click File > New to create a new document.

Related Links
XMetal customizations on page 103
Formatting and authoring functionality are provided by an XMetalL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetal Customization
Guide.

Create a template

Click File > New and select the General tab.

Select Blank XML Document or Blank SGML Document and click Open.
Choose a DTD or Schema to associate with your template.

Add elements and content to the template as required.

Create a folder in the template folder and save the file (for example, . . \ XMet aL
<ver si on>\ Aut hor \ Tenpl at e\ New_pr oduct s\ Z- seri es. xml ).

a s D E

& - . ' - .
"2 Tip: Give the file a descriptive name that reflects the template use or associated DTD.

-
=/ Note: The file extension you assign to your template (.xml or .sgm) determines whether an XML or
SGML file is created when the template is opened.

Related Links
Working with elements on page 105
Elements are the building-blocks of your documents. They are defined in your DTD or Schema.
Authoring in Normal view is similar to applying styles, whereas Tags On view lets you work with
elements as structural objects. You can insert elements using the Element List, the Insert menu, or
the In-place, look-ahead element list.

Create a specialization template on page 196
Once you have configured and re-started XMetal, you can create a template so that authors can
create new documents using your specialization.
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Opening and closing documents

Opening and closing documents

When you open a file, XMetaL Author checks for a DTD, Schema, or Rules file.

To do this

Follow these steps

Open a document

Open a document that is displayed in a Web browser

Close a document

Close all open documents

Click File > Open and choose a file, or drag and drop a file
onto the XMetaL Author title bar

In the Select Files to Open dialog, users can open

a document in Tags On, Normal or Plain Text view.

File navigation options are available in the Select
Files to Open dialog as follows:

« Show Folder - displays the folder for a selected file
to allows users to navigate to the folder where the
file is located.

» Find all files in folders - allows users to view all
files in a selected directory, including sub-folders,
in one list. The file extensions filter allows, including
sub-folders, to narrow down list of file specific types.

« A powerful file preview feature.

Click the file icon in the browser address bar and drag it
onto the XMetaL Author title bar

Click File > Close in the main menu, or right-click and select
Close on the worksheet's tab.

Click File > Close All

When opening a file, XMetalL checks the following conditions and stops as soon as one of the conditions is

true:

« If the file starts with an XML declaration, it is edited as an XML file.
« If the file does not start with an XML declaration and if the filename has the .sgm or .sgml file extension, it

is edited as an SGML file.

If neither condition is true and if the file contains a document type declaration, the file is edited as an XML
file. In this case, XMetaL adds an XML declaration to the document.

If you open an XML document that does not specify a DTD or Schema and the document is not well-formed,

XMetal attempts to fix the markup.

Related Links
Display mode on page 22

You can choose how much space to allocate for displaying your documents. You can also choose
to display your documents in a tabbed interface so that you can easily switch between open

documents.

Special characters and symbols on page 123

You can use the Special Characters and Symbols toolbars, or the Insert Symbols menu (displayed
by using the keyboard shortcut CTRL + Shift + S), to enter characters and symbols that do not have
corresponding keys on US English keyboards. If your document’s encoding supports it, the characters
and symbols themselves (not the character entities) are saved with your document.
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If XMetalL cannot find the DTD, Schema, or Rules file

XMetal customizations on page 103
Formatting and authoring functionality are provided by an XMetalL customization. The basis for an
XMetal customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetal Customization
Guide.

If XMetalL cannot find the DTD, Schema, or Rules file

If XMetaL Author cannot find a DTD, Schema, or Rules file for the document you are opening, you must
choose an option for editing the document.

XMetal may not be able to locate the DTD for any of the following reasons:

 Your document contains no document type declaration.

» There are no entries in the catalog or map files that map the external identifier in the document type
declaration with a DTD.

« The DTD is not at the expected location. An incorrect location may have been specified in the catalog or
map file. (If a relative location was specified, it should be relative to the location of your document.)

Select from the following options:

« Browse for a DTD. Opens a dialog from which you can select a DTD.

» Edit as a partial document. Opens the document as a well-formed document in Normal or Tags On view.
You can edit elements and attributes, but no validation takes place. (Not applicable to XML files based on
Schemas.)

 Edit the file in plain text view. Opens the document in Plain Text view.

Some options let you choose an auxiliary DTD. If you do so, the elements and attributes from the auxiliary
file are added to the document you are editing. However, the auxiliary DTD is not used to validate the document
and you can add elements and attributes as necessary.

x

"C\Users\Publicbest xml”

could not be opened because a DTD coukd not be found.
What would you ke fo do?

" Browse fora OTD

" Edit as a partial document fno niles checking)
r

7 Exdit thie fibs in plain ted view
r

QK I Cancel Help

Related Links
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Document views on page 10
You can choose a view for your document through the View menu or from the view buttons in the
document status bar. The view you select depends on how you want to work with your document.
You can set view options, including a default view through Tools > Options.

Authoring structured content on page 100
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WebDAV-enabled folders

When you create a document instance of a DTD or Schema in Normal or Tags On view, XMetalL
Author ensures that your content is valid by guiding you through the authoring process. You do not
need to have a complete understanding of XML to begin authoring structured content.

WebDAV-enabled folders

To open files in a WebDav-enabled folder, you must have permission. When you open a document in a
WebDAV folder, it is locked for editing. Other users can open the file as read-only. Auxiliary files such as the
DTD are left unlocked.

Customization files can be downloaded from a WebDAV server following the normal search rules. Catalogs
are not downloaded from a WebDAV server; only your local system is searched according to the normal
search behavior for catalogs.

-
) Note: Microsoft Internet Information Server (11S) Version 5.0 must be installed, and the folder containing

the target files must be Web Share enabled.

File caching

Files retrieved through WebDAV are stored in your Temp folder (usually . . \ Docurent s and

Set ti ngs\ <user nanme>\ Local Settings\ Tenp). When you open a file from a WebDAV server, the
URL to this folder is mapped and the cached file is used. If the file in the cache does not exist, the file is
retrieved from the WebDAV folder and placed there. After the document is closed, all the cached items used
by the document are removed.

Related Links
XMetal customizations on page 103
Formatting and authoring functionality are provided by an XMetalL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetal Customization
Guide.

Managing open documents

Documents are displayed in windows in the editing pane. XMetal provides various ways of organizing and
navigating document windows, and navigating to documents outside XMetalL.

Moving between open documents

If you have more than one document open in XMetalL Author, you can move between the open documents
in the following ways:

« Click the appropriate file name on the Window menu
* Press Ctrl+Tab or Ctrl+Shift+Tab
¢ Click Next Document (=)/Previous Document (+) on the Standard toolbar

« Click the "Active Files" downward arrow at the top-right corner of the editing pane and select the open
document you want to view.
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Managing open documents
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atures.xml  CQuick¥MetalMavigation.xml Support_services.xml =

e service options, and support downloads, visit xref: hitp/f

5 at xref” supportxmetal@justsystems com, or telephone us at

al.com/content-about-contact-us/.

Moving worksheet tabs

B | Bug_fixes_and_minor_enhancements.xml
ﬁ- Hello_World_in_MMI¥.xmI
Introduction.xml
Mew_features.xml

QuickXMetalMavigation.xml

Support_services.xml

You can move and arrange open worksheets' tab order by dragging and dropping the tab(s) you want to

move.

Scrolling through worksheet tabs

If more window tabs are open than can be displayed in the editing pane, you can use the arrows at the top-
right of the editing pane to scroll through the windows.

Working with tab groups

Open documents can be grouped in the editing pane into vertical or horizontal tab groups.

\J Note: Only a horizontal OR a vertical tab grouping can be utilized at one time.

To do this

Follow these steps

To create a horizontal tab group

To create a vertical tab group

To move a document to the next
tab group

To move a document to the
previous tab group

To close all documents in a tab
group

To close all documents in a tab

document

group except the currently selected | This.

Right-click on an open document's worksheet tab, and then click New Horizontal
Tab Group.

Right-click on an open document's worksheet tab, and then click New Vertical Tab
Group.

When documents have been grouped into at least two separate tab groups, right-
click on an open document's worksheet tab, and then click Move to Next Tab
Group.

The document is moved to the next group to the right (in horizontal grouping)
or the group immediately below the current group (in vertical grouping).

When documents have been grouped into at least two separate tab groups, right-
click on an open document's worksheet tab, and then click Move to Previous Tab
Group.

The document is moved to the next group to the left (in horizontal grouping)
or the group immediately above the current group (in vertical grouping).

Right-click on an open document's worksheet tab, and then click Close All
Documents in Tab Group.

Right-click on an open document's worksheet tab, and then click Close All But
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Saving documents

£ | Hello_World_in_MMD{xml  Introdudionsxml Mew features.xml QuickXMetalMavigation.xml Support_services.xml 5
r.j I ,..I

Coss 1d” in MMIX ]

Close All Documents in Tab Group | o

MMIX, (pro

is a simple

XML Inc]

Close All but This

Copy Full Path

Show Document on XMetal Deskidp)

MNew Horizontal Tab Group

MNew Vertical Tab Group

=| Tabbed documents options

Disable open documents in tab

Force open documents in tab

Active tab

| < Nat set > ZXK@
| < Not set > %K@

| Save all documents || Close all documents |

*Activate Document in tabbed window to make tab active.

Exit

Viewing documents and document folders outside XMetaL

A document's containing folder can be opened from within XMetal, and the document's full path can be
copied to allow you to quickly navigate to a document's location.

To do this

Follow these steps

To copy a document's full path

To open a document's containing
folder

To open a document's desktop
location in XMetalL

Right-click on an open document's worksheet tab, and then click Copy Full Path.
You can then paste the full path in a directory browser to view the location
and open the document outside XMetalL.

Right-click on an open document's worksheet tab, and then click Open Containing
Folder.

The document's containing folder opens in Windows Explorer.

Right-click on an open document's worksheet tab, and then click Show Document
on XMetalL Desktop.

The document's desktop location is displayed in the Resource Manager
pane.

Saving documents

You can save the current document or all open documents. XMetalL Author validates the document before
saving it. You can save an invalid document or cancel the save operation. You can also set save options
such as automatic saving and backup creation.
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Saving documents

Save one or all documents from the main menu:

To do this Click this
Save a document File > Save
Save a document under a different name or in a different | File > Save As
locati . . .
ocation In the Save As dialog, users can find and filter
content.
File navigation options are available in the Save As
dialog to enable file navigation options such as:
< Show Folder - displays the folder for a selected file
to allows users to navigate to the folder where the
file is located.
Save all open documents File > Save All
Save a document from the worksheet tab:
To do this Click this
Save a document Right-click on the worksheet tab of the document you want
to save. In the menu that appears, click Save.

File naming recommendations

If you are publishing your documents using the DITA Open Toolkit, you are advised to restrict your filenames
to the following characters:

* a-z
e A-Z

* 09

* - (hyphen)

e _(underscore)

Related Links
Options on page 49
You can set options through the Tools menu.

Special characters and symbols on page 123
You can use the Special Characters and Symbols toolbars, or the Insert Symbols menu (displayed
by using the keyboard shortcut CTRL + Shift + S), to enter characters and symbols that do not have
corresponding keys on US English keyboards. If your document’s encoding supports it, the characters
and symbols themselves (not the character entities) are saved with your document.

Authoring structured content on page 100
When you create a document instance of a DTD or Schema in Normal or Tags On view, XMetaL
Author ensures that your content is valid by guiding you through the authoring process. You do not
need to have a complete understanding of XML to begin authoring structured content.
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Character encoding

Character encoding

XMetal Author supports US-ASCII, ISO-8859-1 (Latin-1), and Unicode™ (UTF-8 or UTF-16) character
encoding. By default, XML files that you create with XMetalL Author use UTF-8 encoding.

You can enter Unicode characters using standard input devices such as a keyboard, or IMEs (input method
editors). You can also use the keyboard shortcut CTRL + Shift + S or right-click your mouse and select Insert
Symbol to select a symbol from a contextual menu of commonly used symbols (Note: The list of symbols
can be edited from Tools > Options > Symbols). Alternatively, you can copy and paste characters from

other programs.

Unicode characters are displayed in Normal and Tags On views. If a character appears as a box, then the
font in use does not contain that character. The character will appear correctly when the required font is used.

XMetal Author determines the file encoding by checking the following conditions, in the following order:

1. If the file contains a byte-order mark, UTF-8 or UTF-16 encoding is determined.

2. If the file contains an XML declaration, then the rules in Appendix F of the XML specification
(www.w3.0org/TR/REC-xml#sec-guessing) are used to determine whether the file uses UTF-16 encoding

(that is, the encoding is determined by the ‘<?’ characters in the XML declaration).

3. If the file contains an XML declaration that specifies an encoding string, then this encoding is used.
4. If the encoding cannot be determined, then the default is used: UTF-8 for XML documents and ANSI

(Latin-1) for SGML documents.

Table 29: Supported encoding strings

Encoding Type

Strings

US-ASCII

1ISO-8859-1

ANSI_X3.4-1968
ANSI_X3.4-1986
ASCII

CP367

CSASCII

IBM367
ISO_646.IRV:1991
ISO646-US
ISO-IR-6

us

US-ASCII

CP819
CSISOLATIN1
IBM819
ISO-8859-1
ISO_8859-1
ISO_8859-1:1987
ISO-IR-100
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Creating well-formed XML documents

Encoding Type Strings
LATIN1
L1

UTF-8 UTF-8

UTF-16 UTF-16

J Note: If the XML declaration contains an encoding string not listed in the above table, the file is opened
in Plain Text view.

Related Links
Special characters and symbols on page 123
You can use the Special Characters and Symbols toolbars, or the Insert Symbols menu (displayed
by using the keyboard shortcut CTRL + Shift + S), to enter characters and symbols that do not have
corresponding keys on US English keyboards. If your document’s encoding supports it, the characters
and symbols themselves (not the character entities) are saved with your document.

Creating well-formed XML documents

When you create a blank well-formed XML document, you must define elements and attributes before you
can create content. Because the document is not based on a DTD or Schema no rules checking or validation
occurs.

The Attribute Inspector and Element List display only the elements and attributes that you add to the document.
XMetaL Author inserts the following processing instruction in your well-formed document:

<?xmwel | _fornmed path =
PN

O x|
Generad | (NTA Glossary | DITA Leaming | DITA Map | DITA Topic | Jounaist | Meeting |

®© 8B o

Blal‘l-c_sl::ld._ Blark XML
Dwocument Document

Daocument

Defining an element

1. In the Element List, double-click <Insert Element>.
2. Type a hame.
3. Type a description.

The description will appear at the bottom of the Element List when the element is selected.

4. Choose an option:
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Defining an attribute

« Element can be a container. Choose this option if you want the element to be able to contain text
and other elements.
« Element is empty. Choose this option if you do not want the element to have any content.

x
Mame: |]
Description: [

' Bement can be & contaner (has start- and end4ags; can
contain texd and/or other elements)

I~ Bement is emply has only & stad4ag, and no conterts)

oK |  Cance Hep |

Defining an attribute

1. Insert an element in your document.
A new, blank attribute is created for the element.

2. In the Attribute Inspector, right-click on the new attribute and click Add Attribute.

Attribute Inspector

3. Type a name.
4. Type a description.

The description will appear at the bottom of the Attribute Inspector when the attribute is selected. All new
attributes created in well-formed XML documents have character data (CDATA) content.

xq

Attribute Description: |

ok | cemed | Hep
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Inline attribute editor

Inline attribute editor

64

The inline attribute editor allows users to edit attributes in the element that is under the cursor. All actions

can be completed via keyboard only.

All keyboard shortcuts defined below, except for opening the inline attribute editor, presupposes that it is

open.

To do this

Do this

Open the inline attribute editor

Find an attribute by name or description

Show an attribute's description

Sort attributes

Delete an attribute from an element
Generate a unique ID

Use other utilities for managing reference attributes

Type CTRL + SHIFT + F6 on your keyboard

Enter the search criteria in the search field. The results will
be displayed as you type.

If the search field is hidden, type CTRL+F on your
keyboard to unhide it

Hover your cursor over the name of the attribute and the
description will be displayed in the lower pane.

If the lower pane is hidden, type CTRL + | on your
keyboard to unhide it.

Type CTRL + R on your keyboard to toggle the sorting. You
can sort by default order or alphabetically.

Type CTRL + Del
Type CTRL + N
Type CTRL + ?

Users can also:

» Customize the list of predefined values

* Select an attribute description topic in the DITA Language Specification help system (DITA users only)

* Run custom macros for predefined attributes
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Archiving linked documents

Select utility:
Browse for file... (Ctri+0)

Browse for image... (Ctrl+Shifi+0)
Delete attribute (Ctri+Del)
Generate unigue ID (Ctrl+M)
Make absolute File System path

Make absolute URL
Make relative File System path

Make relative URL
Open referenced WEB Page in XMetal resources tab (Ctrl+S

Open referenced file (Ctrl+Enter)

<image> o m/,ﬁ & @
| / «B
class - topicfimage /
height 34

href JAmagesiwin/DateAnalysisGUl.pn
id image_8BSECAAOA1CBATTCBIBEG3DI2ATIATES
placement inline

Open referenced file with

Open referenced location...

= | | |Setattribute value to Resources tab 'Web Page' URL
Show referenced file on Desktop tab (Shift+Enter)
Show/sort all attributes.._ (Ctri+R)

width
xmllang

BQ MTA Language Specificat
B &
Hide Locate Back

Conterts |ndex Search

[?] simpletable attribu
2] specialization atirit
Iz] Topicref element at
= lul Complex attribute ¢
2] The href attribu
[2] The keys attribe
2] The keyref attri
ﬂ The keyscope i
+ Q The conref attri

(=
2] The conaction :

e 3 The conrefend
2] The conkeyref
2] The type attribe
ﬂ The format attri
fiie: ﬂ The scope attri

< >

i 628
en-lIS
Short description of @href:

Provides a reference to a resource. See The href attribute for detailed informatic Se.lfecf?
supported values and processing implications..

o o

Opticns

Other common attr «

(2] The role attiibu

The @href attribute

The ehref attribute i used to reference
another DITA topic or map, a specific
element mside a DITA topic or map, an
external Web page. or another non-
DITA resource.

The valie of a DITA @href attribute
must be a valid URI reference [RFC
3986]. It is an error if the vale & not a
valid URI reference. An implementation
MAY generate an error message; it
MAY recover from this error condition
by attempimg to convert the value to a
valid URI reference. Note that the path
< >

Archiving linked documents

~

v

™
= % @
[end 4

Australia - English (en-AlJ)
Bangladesh - Bengali (bn-BD)

Belize - English (en-BZ)
Canada - English (en-CA)
Caribbean - English (en-029)
India - Bengali (bn-IN)

India - Enalish (en-IN}

Month field to Janua

The tool for archiving linked documents creates a backup (zip) of files opened in XMetaL editor or files found
in XMetaL "Find in files" cross-files operations, including referenced content and images.

Linked documents are archived in the Archive Linked Documents dialog. To access this dialog, press CTRL
+ ? and then find and select Archive linked documents in the dialog that appears.

To do this

Do this

Find linked documents

Set reference attributes

Set the scope of the archive

Click the Scope field and select the scope from the available
options.

Click the Find linked documents button.

Click the button. In the dialog that appears, select
the attributes you want to add.

@ Note: The Ref. attributes checkbox must be
selected to enable this function.
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Printing

To do this

Select a common folder for all archiving documents

Select the content included in the archive

Copy the list of paths to linked documents to the clipboard

Send a created zip file via email as an attachment

Remove files manually

Set where the path will begin for the folder structure in the
created archive

Add only files with specific extensions to the archive (e.g.,
find and archive images only)

Include all files in the subfolders of the archiving documents
in the archive

Do this

+
il

Click the button to the right of the Input folder field.

Under archiving options, open the Content drop-down
list, and then select one of the available options.

Click the button to the right of the Show field.

After you have created the output successfully, click the
Send [email application name] email button.

When the paths for the found documents are shown, select
the document you want to delete and press Delete on the
keyboard.

In the Path starts with field, select a path from the available
options.

Enter the extension(s) in the File extensions field.

In the Content field, select All files in input folder and
descendants.

[£] Archive linked documents X

Scope: Active document ="} Active document -
Input file: | C:UsersingolovyakiDocuments\XMetal\Samp. oyl | Active map

- -
Input folder: C:\Users\ngolovyak\Documents\XMetal\San ~ J= ?:Lgﬁzgudi?faubm:&sﬁl e
; Find result tab CHECKED files
[ Ref. attributes: [ href.conref,URL FileReffilerefsrcxlinkhrel | P
Show: All linked documents v Ii"—'_J

C:\Users\ngolovyak\Documents\XMetalL\Samples\DITA\AboutWorl

Output file: C\Users\ngolovyakiDocuments\XMi  w ﬁ

—
[ Archiving options

Content: All linked documents

Path starts with:  Children of input folder

*

File extensions:

—

All linked documents ol

All linked documents

All linked documents relocated to input folder
Linked documents in input folder

:;)-AII files in input folder and descendants

Children of input folder
Input folder

Children of input folder

Root folder

Archive Cancel

Find linked documents

Printing

Root folder including drive name

You can print from any document view mode, including Page Preview.
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Working with a repository

To do this

Follow these steps

Print a document

Print a document in Page Preview mode

Click File > Print. Click Options to create headers and

footers.

Right-click in the browser pane and choose Print.

Working with a repository

XMetal Connector is an integration layer that lets you access your repository through XMetalL Author dialogs

and menus.

B
\

to your repository documentation for details.

Table 30: Common repository operations

~ Note: Operation availability is determined by the adapter (a software driver for your repository). Refer

To do this

Click this

Notes

Open a topic or map file

Create a new repository file

Create a new repository map

Open a document that you have
checked out

Explore a repository

Check in a document

Check out a document

Undo checkout of a document

Repository >
Open from
Repository

Repository >
New from
Repository
Template

Repository >
New Map from
Repository
Template

Repository >
Open
Checked-Out
Document

Repository >
Explore
Repository

Repository >
Check In
Document

Repository >
Check Out
Document

Repository >
Undo
Checkout

When you open a topic or map
reference from a repository map,
you have the option to view the
file or check it out for editing (if
enabled).

Select a template. When you add
referenced components (for
example, images and links) to the
new file, you have access to
repository-specific operations
(such as advanced search) if your
adapter supports it.

Select a template.

You may check in a document
only if it is currently open for
editing.

You may check out a document
only if it is currently open for
viewing. When you check out a
document, the current view of the
document is replaced with the
latest version of the document.

The document reverts to its
previous version.
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Working with a repository

To do this

View document or map properties

Set the URL for the default
repository

Log on to a repository

Log off from a repository

Click this

Repository >
Document
Properties

Repository >
Repository
Options

Repository >
Log On to
Repository

Repository >
Log Off from
Repository

Notes

You must set the URL for the
repository before accessing files
for the first time or if you switch
repositories.

Some repositories require that
you log on before any repository
operations are allowed.

= . ) . .
~ Note: When you open a DITA-based repository map file, you have the option of downloading all referenced

components (for example, reusable components). You may wish to do this in order to improve performance.

Adapter configuration file

set to true.

Related Links

68

Toolbars on page 17

Configuration files are located at . . \ XMet aL x. x\ Aut hor\ CRCL\ conf i gs. Each adapter instance must
have a configuration file.

& . . . .
~ Note: Only one configuration file can have the def aul t attribute of the <Adapt er | nst ance> element

You can show/hide toolbars, create new toolbars, or modify existing ones through View > Toolbars.
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Editing documents

A full suite of editing tools is available to assist you in the authoring process. Although they are similar to
those found in many word processors, some are structure-aware.

You can cut, copy, and paste selections using menu commands, shortcut keys, or by drag-and-drop.

To do this

Follow these steps

Cut (Copy) and paste a selection

Delete a selection

Click Edit > Cut (Copy), move your cursor to the desired
location and click Edit > Paste

Click Edit > Delete

e Note: You cannot delete a selection if it includes required elements, and you cannot paste a selection

that would cause the markup to become invalid.

Selecting tags and text

Selection behavior is similar to that in word processors, but selection rules prevent you from creating an
invalid document. If you select a start (or end) tag, your selection is extended to include the corresponding

end (or start) tag and all of the text in between.

To do this

Follow these steps

Select a single word
Select a single element

Select consecutive elements

Select the entire contents of a document

Double-click the word you want to select
Click Edit > Select Element

Click anywhere in the first element to be selected and drag
the cursor until all of the elements are selected

With the insertion point anywhere in the document, press
Ctrl+A

The following examples show text and markup selections in Tags On view.

) CamerasinFocus.xml

g==> g Conclusions am

8((=1e3

e ENFEIN e found that (CEmehesesthe quality of digital cameras have improved
since last year, making the decision whether or not to stick with traditional 35mm film cameras much
maore difficult. The additional price of the digital camera will be offset by the costs of film and
processing, so if vou take a lot of pictures, an investment in a quality digital camera like the ones

reviewed above may pay for itself before you know it.

Mty gl el P e B S e R i B0 it B s it

) CamerasinFocus.xml

Conclusions
EFara» All in all, we found that [SISIR

S| have improved

since last vear, making the decision w el‘her or not to 5t|l: 1-.1Lh Lrad.ltmna] 35mm film cameras much
more difficult. The additional price of the digital camera will be offset by the costs of film and
processing, so if vou take a lot of pictures, an investment in a quality digital camera like the ones

reviewed above may pay for itself before you know it.

o, A ek A e i R i sl e I e e gt A e it i b gl
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Finding and replacing text

) CamerasinFocus.xmi

mm(:onclusicni-;@

s improved
na.l 35mln film cameras much
more difficult. The additional price of the dlglta] camera will be offset by the costs of film and
processing, so if vou take a lot of pictures. an investment in a quality digital camera like the ones
reviewed above may pay for itself before you know it.
st il ettt o . ogaeted  pammes o i gt aanlP i B ba . il e b b B

Finding and replacing text

You can search for a text string and replace it with different text or with a text entity. You can also restrict
your search to a text string that occurs within a specific element.

To do this Follow these steps
Find and replace text Click Edit > Find and Replace.
Find and replace text within a specified element Click Edit > Find and Replace. Then click Options and

select an element.

Find and replace text with an entity reference Click Edit > Find and Replace. Then click Options and
select Replace with entity.

Choose from the following search options:

* Match case. Finds only text that matches the text and case specified.

* Match whole words only. Matches a sequence of one or more whole words only.

« Use Pattern Matching. Searches by pattern, using special search characters.

» Search backwards. Searches from the current location towards the beginning of the document.

« Wrap. Searches from the current location to the bottom of the the document, and then continues searching
from the top of the document.

« Ignore read-only on replace. Ignores read-only elements when replacing text. (If this option is not chosen,
an error message appears whenever you attempt to replace text within a read-only element.)

» Highlight all occurrences. Highlights all occurrences of the searched for text phrase.

XMetal Author - Find and Replace @

Text lEIament] Entity }

Find: Find

Replace with:

Options

[ Match case [ wirap |
[ Match whole words anly Ignare read-only on replace i
[ use pattern matching Highlight all occurrences il
[ search backwards [ Replace with entity

Within element: -

[ Options + | [ Close ] [ Help

Find and replace operations are designed to keep your document valid:
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Search patterns

» Text searches do not find a match if part of the text is found in a separate element. For example, if you are

searching for ‘World Wide Web’ and ‘Web' is in an <EMPH> element, no match is found.

* In Normal and Tags On views, element replacements that would invalidate the markup do not occur if rules

checking is on.

Related Links

Finding and replacing across files on page 87
You can perform cross-file searches to find text or markup using simple text and pattern matching
all the way up to very advance XPath expressions.

Search patterns

When you use pattern matching to find words, the characters in the Find box are interpreted as patterns. That
is, the search text can contain special search characters that match a class of text strings, or markup constructs.
If your search text does not contain any special characters, the text is searched for exactly as entered.

The following special characters can be used:

*

2+ 08 ]

To search for any special character as ordinary text when Use Pattern Matching is selected, precede it with
a backslash (\). For example, use ‘\' to match a period (.).

XMetal Author - Find and Replace

—_—

(| Text |Bament | Entity
Find:
]

Replace with:

Oplans
[Imtatch case
[ Match whole words only

Within glament:

Cwrap
[ tgnore read-only on replace
[Replacs with sntity

[(optonss | [ gose | [ e |

Table 31: Pattern summary

Expression

Matches

Example

ordinary character
<name or <name>

&name or &name;

X*

(pattern)*

X+

(pattern)+

itself

the element name
the entity name

any single character

0 or more occurrences of the
character x

0 or more occurrences of the pattern

1 or more occurrences of the
character x

1 or more occurrences of the pattern

“abc” matches “abc”

“fo.d” matches “food”

“I*ama” matches “llama”

“b(an)*a” matches “banana”

“be+n" matches “been”

“b(an)*a” matches “banana”
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Finding and replacing elements

Expression

X?

(pattern)?
patternl | pattern2

pattern

pattern$

[string]
[~string]
[charl-char2]
[~charl-char2]

\n

\0

Matches

0 or 1 occurrences of the character
X

0 or 1 occurrences of the pattern
patternl or pattern2

pattern immediately following
markup

pattern immediately before markup

any single character in the string
any single character not in the string
any character in the range

any character not in the range

in a replace string, it is replaced by
the text matched by the nth sub-
expression in brackets in the search
string

in a replace string, it is replaced by
the text matched by the entire
search string

Example

“colou?r” matches “color” and “colour”

“b(an)*ale” matches “banale” or “bale”
“(love|money)” matches “love” or “money”

““Note” matches “Note” at the start of a paragraph (as
in <p>Note...</p>)

“sub$” matches “sub” at the end of a paragraph (as in
<p>...sub</p>)

“t[ailn” matches “tan” and “tin”

“th[*e]n” matches “than”, but not “then”

“[a-c]” matches “a”, “b”, or “c”

“["a-c]” matches none of the characters “a”, “b”, or “c”

If the search text is “(.)read” and the replace text is
“\1ox”, the result is “box”

If the search text is “fish” and the replace text is “gone
\0ing”, the result is “gone fishing”

Finding and replacing elements

72

In Normal and Tags On views, you can search for a specific element in your document and replace it with a
different element if doing so does not invalidate the markup. Only the element tags are changed; the element
content does not change.

To do this

Follow these steps

Find and replace an element

Click Edit > Find and Replace and click the Element tab

Searching for attribute

values

You can search for elements with specific attribute values. For example, you can search only for <p> elements
that have a t r ansl at e attribute value of ‘yes’ and replace them with a value of ‘no’:

XMetal Author - Find and Replace

TEJIK. Blement .Eﬂh'.'p‘
Figd:
<p translate="yes">
Replace with:

=p franslate="na">

[ Optisns

#) [ geee ][

Heo |

If a found element has more than one attribute value set, only those that are specified in the replacement

text are modified.
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Finding and replacing entities

Removing an attribute
If you need to remove an attribute, you have the following options:

« Delete the attribute value in the Attribute Inspector. If the value is currently set to an empty string, enter a
new temporary value, press Enter, and then delete the value.

« Switch to Plain Text view and modify the source.

Finding and replacing entities
In Normal and Tags On views, you can search for an entity reference and replace it with a different entity
reference or with text.

To do this Follow these steps

Find and replace an entity reference Click Edit > Find and Replace and click the Entity tab.

Find and replace an entity reference with text Click Edit > Find and Replace and click the Entity tab.
From the options, choose Replace with text.

For example, you can search for the product name entity &or odnamne; and replace it with the product name
text ‘Z9000'.

XMetal Author - Find and Replace

Text | Bemedt Entity | )

Find: Find
Bprodname; ~
Rleplace with: E
20000 L Replace Al
Oplions

Owrae
[ tgrore read-anly on replace

= F‘Eph:: with bex

("] 5eardh badmards

‘Within glement: -

[ gotonsz | [ gose |[ wew |

Checking your spelling

You can check your spelling using the spell checker or as you write by using background spellchecking.

The spell checker in XMetaL helps you eliminate spelling mistakes. The spell checker also includes tools that
can help you customize the preferences to create the experience you want. You can spell check a document
all at once after finishing a document or you can use background spellchecking that uses wavy red lines to
allow you to identify possible mistakes while you work.

Related Links
Using the spell checker on page 74
You can check your spelling using the spell checker.

Using the background spell checker on page 78
You can check your spelling as you write using background spell-checking.
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Using the spell checker

Main word lists on page 80

Main word lists are the built-in word lists for a given language. The default main word list is determined
by the language you select. You can use more than one main word list to check your document.

User word lists on page 81

User word lists are unigue to your XMetalL Author setup or document. You can add words to your
user word list and tell Spell Checker to skip them, replace them with a different word, or suggest

alternatives for them.

Using the spell checker

74

You can check your spelling using the spell checker.

To do this

Follow these steps

Replace a single occurrence of a word

Replace all occurrences of a word
Skip an occurrence of a word or phrase

Skip all occurrence of a word or phrase (and add it to the

Click Tools > Spell Checker. In the spell checker, click
Start. When checking stops at a misspelled word, choose
a word from the Replacements box and click Replace.

Click Replace All
Click Skip Once
Click Skip All

user word list for the document)

You can use the spell checker in the following ways:

» Check the spelling in an entire document, part of a document, or only selected text.

« Manually edit text and then resume checking the document.

« Ignore a spelling error once but flag subsequent occurrences of the problem, or ignore the error for the rest
of the proofreading session.

» Replace words by choosing a word from a list of available words, by typing in the correct word, or by defining
an automatic replacement for a word (especially useful for words that are regularly misspelled).
J Note: The spell checker does not check processing instructions, comments, hidden elements, entity
references, or form fields.

E x|
Spal Checker | Thesaunus - -
Replace with: | . Stan
Fleplacements: st
Oipiang =
Add..
Cheack: Dacumernt L
Ready: | Bagin spell checking
[ Cloas J [ Helg

Word lists

Spell Checker checks spelling by comparing words in your document with the words in one or more lists of
acceptable words. Word lists are categorized as follows:

« Main word lists on page 80
» User word lists on page 81
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Spell checker options

The spell checker checks the user word lists before the main word lists.

Related Links
Using the background spell checker on page 78
You can check your spelling as you write using background spell-checking.

Main word lists on page 80
Main word lists are the built-in word lists for a given language. The default main word list is determined
by the language you select. You can use more than one main word list to check your document.

User word lists on page 81
User word lists are unique to your XMetaL Author setup or document. You can add words to your
user word list and tell Spell Checker to skip them, replace them with a different word, or suggest
alternatives for them.

Spell checker options
You can specify Spell Checker options through Tools > Spell Checker. Your settings are applied the next
time you open the spell checker.

Option Description

Auto Start Starts spell checking automatically from the beginning of
the document when you open the spell checker.

Beep On Misspelled Sounds an alert when the spell checker finds a word it does
not recognize.

Recheck All Text Re-checks all spelling from the beginning of the document
when you interrupt the spell checker and then click Resume.

Check Words With Numbers Checks for words that contain numbers (for example, postal
codes).

Check Duplicate Words Checks for duplicate words.

Check Irregular Capitalization Checks for incorrect capitalization (for example, two upper
case letters at the beginning of a sentence).

Prompt Before Auto Replacement Asks for user input before replacing a word.

Show Phonetic Suggestions Suggests words that sound similar to a flagged word.

Spel Checker | Thesaune

Replace wath: Shart

Replacamenls:

L
Liser Wiord Lists. ..

Chack 0| r‘::;:;:r:l Ligte,..
Ready: | Bagin spell checking "
Buto Stark
Cloge Beep On Misspelied

Reched: Al Text

Check Words With Numbers
v Chiedk Duplicate Words
w Chedk Iregular Capitalzation
v Prompt Before Auto Replacement
w Shaw Phonetic Suggestions

Controlling the active dictionary via xml:lang
The xml:lang attribute value can be used to control which dictionary the spell checker uses.

© 2023 JustSystems Canada, Inc. 75
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76

Whenever a spell checking action is in progress, the xml:lang attribute value will be inspected to determine
if a different dictionary should be used instead of the default dictionary. The following table described INI
variables that correspond to a particular dictionary, setting the INI variable to the xml:lang value you wish to
map to that dictionary:

Table 32: Table of INI Variable Names, Default Values, Internal Codes, Standard Codes and Recommended Values

WT INI Variable | WT Legacy 1ISO-639-1 1ISO-639-2 Recommended |WT Files
Name Internal INI Value

Language Code

Default Value

WT_AFRIKAANS | AF af afr af;afr WT10LDAF.DLL
WT_CATALAN CA ca cat ca;cat WTI10LDCA.DLL
WT_CZECH (V4 cs ces, cze cs;ces;cze WT10LDCZ.DLL
" Note: Both
codes are
considered
synonyms
and should
be treated
equally.
WT_DANISH DK da dan da;dan WT10LDDK.DLL
WT_DUTCH NL nl dut, nid nl;dut;nld WT10LDNL.DLL
D
2/ Note: Both
codes are
considered
synonyms
and should
be treated
equally.
WT_ENGLISH EN en eng en;eng WT10LDEN.DLL
WT_FRENCH FR fr fra, fre fr;fra;fre WT10LDFR.DLL

‘C Note: Both
codes are
considered
synonyms
and should
be treated
equally.

WT_GALICIAN GA gl glg gliglg WT10LDGA.DLL
WT_GERMAN DE de ger, deu de;deu;ger WT10LDDE.DLL

Py

[

~/ Note: Both
codes are
considered
synonyms
and should
be treated
equally.
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Controlling the active dictionary via xml:lang

WT INI Variable
Name

WT_GREEK

WT_ICELANDIC

WT_ITALIAN
WT_NORWEGIAN
WT_PORTUGUESE
WT_RUSSIAN
WT_SLOVAK

WT_SOTHO
WT_SPANISH
WT_SWEDISH
WT_TSWANA
WT_TURKISH

WT Legacy
Internal
Language Code
Default Value

GR

IS

{NULL}
ES
sV
{NULL}
TR

1ISO-639-1

el

no
pt
ru

sk

es
sV
tn

tr

1ISO-639-2

gre, ell

e

"y

¢l

ice, isl

&

-

ita
nor
por

rus

slo, slk

=
%

=

sot

spa

swe

tsn

tur

INI Value

el;ell;gre

Note: Both
codes are
considered
synonyms
and should
be treated
equally.

Note:
Ancient
Greek (before
the year
1454) is "grc"
and | assume
it is not
supported by
the spell
checker.

is;ice;isl

Note: Both
codes are
considered
synonyms
and should
be treated
equally.

it;ita
no;nor
pt;por
ru;rus
sk;slk;slo
Note: Both

codes are

considered

synonyms

and should

be treated
equally.

st;sot
es;spa
sv;swe
tn;tsn

trtur
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Recommended

WT Files

WT10LDGR.DLL

WT10LDIS.DLL

WT10LDIT.DLL
WT10LDNO.DLL
WT10LDPO.DLL
WT10LDRU.DLL
WT10LDSL.DLL

WT10LDST.DLL
WT10LDES.DLL
WT10LDSV.DLL
WT10LDTN.DLL
WT10LDTR.DLL
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WT INI Variable
Name

WT_XHOSA
WT_ZULU
WT_NOLANGUAGE
WT_ENGLISH AUS
WT_ENGLISH_CAN
WT_ENGLISH_UK
WT_ENGLISH_US
WT_FRENCH_CAN

WT_FRENCH_NAT

WT_GERMAN_NAT

WT_GERMAN_SWI

WT PORTUGLESE BR
WT PORTUGLESE FO
WT SPANISH AVER
WT SPANISH SPAIN
WT_NODIALECT

WT Legacy
Internal
Language Code
Default Value

{NULL}
{NULL}
{NULL}
0z
CE
UK
us
CF

FR

DE

SD

BR
PO
EA
ES
{NULL}

1ISO-639-1

en-au
en-ca
en-gb
en-us

fr-ca

fr-fr

de-de

de-ch

pt-br
pt-pt
es-us

es-es

1ISO-639-2

xho

zul

ZXX

eng-AU
eng-CA
eng-GB
eng-US
fra-CA, fre-CA

fra-FR, fre-FR

deu-DE, ger-DE

deu-CH, ger-CH

por-BR
por-PT
spa-US
spa-ES

ZXX

Recommended
INI Value

xh;xho

zu;zul

ZXX
en-AU;eng-AU
en-CA;eng-CA
en-GB;eng-GB
en-US;eng-US

fr-CA;fra-
CA;fre-CA

fr-FR;fra-
FR;fre-FR

de-DE;deu-
DE;ger-DE

de-CH;deu-
CH;ger-CH

pt-BR;por-BR
pt-PT;por-PT
es-US;spa-US
es-ES;spa-ES

ZXX

WT Files

WT10LDXH.DLL
WT10LDZU.DLL

WT10LDDE.DLL

WT10LDDE.DLL

WT10LDPO.DLL
WT10LDPO.DLL
WT10LDES.DLL
WT10LDES.DLL

Using the background spell checker
You can check your spelling as you write using background spell-checking.

Background spell-checking displays red, wavy lines for any misspelled word to let you easily see and correct
spelling mistakes. You can also choose to correct a word that is highlighted as misspelled. Background spell-
checking also includes a feature that automatically replaces misspelled words as you type, using words from
the user word lists and main word list (if only one match exists).

You can use background spell-checking in the following ways:

» View misspelled words as soon as you have typed them.

« Allow the background spell-checking feature to automatically correct words that are similar to words in the
main or user word lists.

« Manually correct words that are similar to words in the main or user word lists.

r

“~/ Note: Background spell-checking is on by default.

Related Links

78

Turning on background spell-checking on page 79

Background spell-checking can be turned on or off. The change affects all documents.

Automatically correcting spelling on page 79
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Turning on background spell-checking

You can set up XMetal to automatically correct misspelled words that are similar to words in the
main word list or user word lists. This feature is triggered for an individual word only when the
spacebar is pressed immediately after that word.

Manually correcting spelling on page 79
You can manually correct misspelled words with words from the main word list and user word lists.

Turning on background spell-checking
Background spell-checking can be turned on or off. The change affects all documents.

1. Click Tools > Options.
2. In the General pane, select the Check spelling while typing check box.

3. Click OK.
The Options dialog box closes and changes are made to your settings.

Related Links
Automatically correcting spelling on page 79
You can set up XMetalL to automatically correct misspelled words that are similar to words in the
main word list or user word lists. This feature is triggered for an individual word only when the
spacebar is pressed immediately after that word.

Manually correcting spelling on page 79
You can manually correct misspelled words with words from the main word list and user word lists.

Automatically correcting spelling

You can set up XMetalL to automatically correct misspelled words that are similar to words in the main word
list or user word lists. This feature is triggered for an individual word only when the spacebar is pressed
immediately after that word.

& . . . .
2 Note: Text in hyperlinks is not automatically corrected.

1. Click Tools > Options.
2. To automatically replace misspelled words, select the Replace words from my word list while typing
check box.

3. Click OK.
The Options dialog box closes and changes are made to your settings.

Related Links
Turning on background spell-checking on page 79
Background spell-checking can be turned on or off. The change affects all documents.

Manually correcting spelling on page 79
You can manually correct misspelled words with words from the main word list and user word lists.

Main word lists on page 80
Main word lists are the built-in word lists for a given language. The default main word list is determined
by the language you select. You can use more than one main word list to check your document.

User word lists on page 81
User word lists are unique to your XMetal Author setup or document. You can add words to your
user word list and tell Spell Checker to skip them, replace them with a different word, or suggest
alternatives for them.

Manually correcting spelling
You can manually correct misspelled words with words from the main word list and user word lists.

1. Place your mouse cursor over a misspelled word that is highlighted and right-click your mouse.

© 2023 JustSystems Canada, Inc. 79



Main word lists

A menu appears and displays options for correct spelling.

2. Select one of the listed options.
The misspelled word is replaced by the selected word from the main word list or user word lists.

Related Links
Automatically correcting spelling on page 79
You can set up XMetalL to automatically correct misspelled words that are similar to words in the
main word list or user word lists. This feature is triggered for an individual word only when the
spacebar is pressed immediately after that word.

Turning on background spell-checking on page 79
Background spell-checking can be turned on or off. The change affects all documents.

Main word lists on page 80
Main word lists are the built-in word lists for a given language. The default main word list is determined
by the language you select. You can use more than one main word list to check your document.

User word lists on page 81
User word lists are unique to your XMetaL Author setup or document. You can add words to your
user word list and tell Spell Checker to skip them, replace them with a different word, or suggest
alternatives for them.

Main word lists

Main word lists are the built-in word lists for a given language. The default main word list is determined by
the language you select. You can use more than one main word list to check your document.

To do this Follow these steps

Add a main word list Click Tools > Spell Checker. In the spell checker, click
Options > Main Word Lists. Then click Add List and
choose a list.

Remove a main word list Click Options > Main Word Lists. Then click Remove List
and choose a list.

Main Word Lists 7]

Current Lengusge: Englzhdll &, jUS)

Main woed lists — ——
- \Program Files\Corel\Shared\ W Metal \wibng Tools\1]j Agdd List... )

Claze

Help

Related Links
Using the spell checker on page 74
You can check your spelling using the spell checker.

Using the background spell checker on page 78
You can check your spelling as you write using background spell-checking.

User word lists on page 81
User word lists are unique to your XMetalL Author setup or document. You can add words to your
user word list and tell Spell Checker to skip them, replace them with a different word, or suggest
alternatives for them.
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User word lists

User word lists

User word lists are unique to your XMetalL Author setup or document. You can add words to your user word
list and tell Spell Checker to skip them, replace them with a different word, or suggest alternatives for them.

To do this Follow these steps

Set the default user word list Click Tools > Spell Checker. In the spell checker, click
Options > User Word Lists. Then choose a word list and
click Set Default.

Add a user word list Click Tools > Spell Checker. In the spell checker, click
Options > User Word Lists. Then click Add List and
choose a word list.

User word list files have the extension ‘.uwl’. The word list that is installed by default is WT10xx.uwl (where
‘xx"is a language code). This file is available to any document created or edited in your setup of XMetalL
Author. If you have more than one of these lists installed on your system, you can add or remove them from
the set of word lists that the spell checker uses for your document.

The spell checker checks the default user word list before it checks the other user word lists or main word

list(s) In addition to the default word list, each document has its own word list.

J Note: When you ignore a word during spell checking by clicking Skip All, that word is added to the
document user word list.

Curent Language: Englshll. 5. (US)

gt el st

Diocument Word List [ Addlia. |
WTTOUS LWL 2
% hubewList WL [ Femoave List |

[ Set Delaul ]

Adding an entry
To add an entry to the user word list:
1. Click Tools > Spell Checker.

2. Click Options > User Word Lists and select a word list.
3. Do one of the following:

« Enter the word in the Word/phrase text box
< Add a misspelling or a phrase that you want the spell checker to replace automatically and enter the
replacement in the Replace with text box

4. Click Add Entry.

© 2023 JustSystems Canada, Inc. 81



Deleting an entry

User Word Lists 7]

Curent Language: Enghzhell. 5. [US) Change..
Lz ward Bsts

Document Weed List A Ligt..,
WTTIOUS WL

i el yh ezt LWL Remave List
St Drslult

WUz ward izt corrents
“Worddphiass: Feplacs with .

& goad lime was had <SUBJECT> hisd & gaod timd ." Add Ertiy

Related Links
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Deleting an entry on page 82
Changing the replacement text for an entry on page 82
Changing an entry on page 82

Deleting an entry
To delete an entry in a user word list:
1. Click Tools > Spell Checker.

2. Click Options > User Word Lists and select a word list.
3. Select an entry in the Word/phrase text box and click Delete Entry.

Changing the replacement text for an entry

To change the replacement text for an entry in a user word list:

Click Tools > Spell Checker.

Click Options > User Word Lists and select a word list.

Select an entry in the Word/phrase text box and edit the text in the Replace With text box.
Click Replace Entry.

P wbdpE

Changing an entry

To change an entry in a user word list:

Click Tools > Spell Checker.

Click Options > User Word Lists and select a word list.

Select an entry in the Word/phrase text box and click Properties.
Choose an option:

Hw DR

e Skip word. Select this option if you do not want the spell checker to flag the word as incorrect.

« Auto-replace entry. Select this option if you want the spell checker to automatically replace any
instance of the word or phrase in your document with the text in the Replace with text box.

» Exception entry. Select this option if you have multiple Replace with entries for one word and you
want the spell checker to ask you which replacement text to use when it encounters the word in a
document.

5. Edit the text in the Word/Phrase text box as required.
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Language settings

This is the text that the spell checker finds (or ignores).

6. Edit the text in the Replace with text box as required.

If you want to enter more than one choice for replacement text (for Exception entry types), each choice
must be on a separate line in the Replace with text box.

p

—~/ Note: If the Auto-replace entry option is enabled, any text in the Replace with text box is ignored.

Language settings

You can choose a language for the current file or set it as the default language for the spell checker and
thesaurus. You can also add and remove languages.

To do this Follow these steps

Set the default language Click Tools > Spell Checker. In Spell Checker, click
Options > Language. Then enable the Save as default
Writing Tools language option and choose a language.

Add a language Click Options > Language. Then click Add and type a two-

letter code for the language you want to add (the code must
be unique) and a description (the name of the language).

Remove a language Click Options > Language. Then select a language and

click Remove.

You can use the spell checker to format dates, time, currency symbols, and other text according to a language
convention (for example, “12 avril 1996 for a French document).

Select Languapge Wl
Language oK
E niglizh-LLE, LK, ~
EF T [ Cacel
EnkL L [ Concal ]
Finrizh sU H
Frrish AT} [IJ
FrenchCansdun OF
Franch alional FR Add
P E (pse )
Gemar-ational DE
Fistman- S i e

Show avalable languages only

ave a3 default Wribng Todls language

Related Links
Checking your spelling on page 73

You can check your spelling using the spell checker or as you write by using background
spellichecking.

Using the thesaurus on page 84

You can look up a word and display synonyms, antonyms, and other related information using the
thesaurus.

Checking a selected word's spelling and synonyms

The word that is currently under the cursor can be checked with the hot key Ctrl + . (Ctrl + period).

The word is checked as follows:
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Using the thesaurus

« If the word is misspelled, correct words are proposed in the dialog that opens.
« If the word is spelled correctly, a list of synonyms, antonyms and groups of related words are displayed.

You can navigate forward and backward between the lists of proposed words. Every related word can have
its own list of related words, and it's possible to return back or move forward in the search chain.

a new m or an update to the current version is available.
| version (5
[w| [ ] [
yboard Synonym(s): ¥ ments.

ion |adaptation —
ren dP:;Lring Select group of suggestions ]
a new ;
translation Synonym(s):
interlingual rendition Related meaning(s):
interpretation Similar to:
yboard|reading
Child type:
i Has parts:
on
Related and synonymis):

a new version or an update to the cur -
Details:

interpretation, type, writing, written material, written account,

written record, representation, internal representation, mental

wboard shortcuts enables more lease representation

ion

a new version or an update to the current version is available.

Using the thesaurus

You can look up a word and display synonyms, antonyms, and other related information using the thesaurus.

To do this Follow these steps

Replace a word using the thesaurus Select a word in your document, click Tools > Thesaurus,
and click Look Up. Expand the desired definition to display
a list of synonyms and other words. Choose a word and
click Replace.

Insert a word from the thesaurus Look up a word in the thesaurus and expand the desired
definition to display a list of synonyms and other words.
Choose a word and click Insert.
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Thesaurus options

-} CamerasinFocus.xml

Introduction
The newest ieneramn of affordable, high-resolution digital cameras delivers prints that are nearly
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Thesaurus options

You can specify thesaurus options through Tools > Thesaurus. Your settings are applied the next time you
open the thesaurus.

Option Description

Auto look-up Displays the thesaurus entry for the current word when the
thesaurus is opened.

Auto close Closes the thesaurus after you insert a word in your

document.

Spelling assist

Suggests alternate spellings if the word is spelled incorrectly
or not found in the thesaurus.

Synonyms Displays words that have the same or similar meaning as
the word being looked up.

Antonyms Displays words that have an opposite meaning.

Set data file Sets a language-specific data file for the thesaurus.

Spell Chacker | Thessurs

9 (ot )

W
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Tracking your changes

Tracking your changes

In Normal and Tags On views, you can display changes as marked insertions or deletions. When change
tracking is active, text that is inserted in a document appears in a distinctive color or formatting. You can hide
text that has been deleted, or you can display it in a distinctive color and with strikethrough formatting.

To do this

Follow these steps

Turn on (off) track changes

Scroll through changes

Accept (reject) all changes

Accept (reject) changes one at a time

Click Tools > Track Changes

Click Tools > Accept or Reject Changes. Then click Find
previous (Find next).

Click Tools > Accept or Reject Changes. Then click
Accept all (Reject all).

Click Tools > Accept or Reject Changes. Then click
Accept (Reject).

The following types of changes can be tracked:

 Text inserted or pasted
* Text deleted or cut
 Text moved by drag-and-drop

Changes can be accepted or rejected on an individual or global basis. When marked changes are accepted,
the changes are incorporated into the document and the revision marks are removed. When marked changes
are rejected, the changes are removed, and the deleted text (if any) is restored to the document.

e Note: When rules checking is active, changes that are necessary to make the document valid are not

rejected.

Introduction

| The
nearly indistinguishable froge
digital camera has gone froffeesi LN EY 03

a 1,280 by 1,024 resolution|
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&

+ Built In Flash - recom
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Reiect |
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no film processing costs but]

ady for use in minutes.

Related Links
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Options on page 49

Once uploaded into your computer, the images are ready to post to the web, placed jn a presentation

You can set options through the Tools menu.
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Cross-file Operations

Cross-file Operations

You can perform certain actions or operations, such as finding text or spell checking, across multiple files.

You can perform certain actions or operations, such as finding text or spell checking, across multiple files.
You will have the option to choose from several different locations, including the DITA Maps currently open,
all open documents, and the current document.

Finding and replacing across files
You can perform cross-file searches to find text or markup using simple text and pattern matching all the way
up to very advance XPath expressions.
You can search for text, markup, and XPath expressions with the Find in Files feature. The results will be

displayed in the Results pane. The results will be sorted alphabetically by filename. You can remove, select,
highlight and replace results, as well as perform new searches on the results.

Double-clicking on a search result opens the containing document.
Find text across files
You can search across files for text. The Find in Files dialog box can be opened from the editing pane or

Map Editor. Results can be displayed on one of two pages, allowing you to keep the results of two searches
displayed at one time.

1. Click Edit > Find in Files.
The Find in Files dialog box opens.

=] Find in Files [

Teut Markup #Path
Find what:

Texst: | -

Look in: XMEE . ditamap - Browse
7| Look in subfolders
Optiore:

Match case 7| Match whole phrase Use patterm matching

Match whale words only Match all words Use regular expression matching
Results:

@ Find 1 results window

Find 2 results window

Find | | Close: | | Help

2. Enter the search string in the Text field.

3. Select the search location from the Look In drop-down list. Alternatively, click Browse to browse for the
search location. The following options are available in the Look In drop-down list:

« All Open Documents - searches all documents (topic and map files) that are currently open

« Current Document - searches the topic file you have currently open

* [currently active map file] - searches all files in the currently active map file in the Map Editor (the name
of the map is displayed in the drop-down list)

e Checked files in: Find [1 or 2] Results pane - searches the already checked files in the Find 1 or 2
Results pane (Note: This option is only available when initiating a search from the Find 1 or 2 Results
pane)
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Find markup across files

4. Select Look in subfolders to include in the search all subfolders located under the folder of the file you
are searching.

5. (Optional) Select from one of the following options:

Match case - search results include only words that have the same capitalization as the search word
Match whole words only - search results will only be returned for word matches with a whitespace
occurring on either side of the word. (For example, if searching for ‘'use’, only occurrences of the word
‘use' are found, and search results will not return words such as 'user' or 'uses'.)

Match whole phrase - when searching for a phrase, results are returned only for the exact series of
words being searched

Match all words - search results only include files that contain all the search words in any location
within the searchable document(s). The words can be in any order, and do not have to be displayed
in any sequence.

Use pattern matching - see Search patterns on page 71

Use regular expression matching - see definition of regular expression

6. Select the Find 1 or Find 2 results pane to display results.

7. Click Find.
Results are displayed in the selected window in the Results pane. Double-clicking on a search result
opens the containing document.

Related Links
Finding and replacing text on page 70

You can search for a text string and replace it with different text or with a text entity. You can also
restrict your search to a text string that occurs within a specific element.

Find markup across files on page 88

You can search for occurrences of specific elements or attributes across files.

Find markup using XPath expressions on page 89

Find markup using XPath expressions.

Find markup across files
You can search for occurrences of specific elements or attributes across files.

1. Click Edit > Find in Files.
The Find in Files window opens.

=] Find in Files Lx ]

T [

HPath |

Find what:

Element: |An}lelemenl j ‘exists j

Attribute: |An}l attribute j ‘exisls j

Look in: |><MEE ditamap ﬂ Browse...

Look in subfolders

Results:
() Find 1 results window

@ Find 2 results windaw

Find Cloze Help

2. Click the Markup tab.

88
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Find markup using XPath expressions

3. Specify the Elements or Attributes you want to find, along with one of the following options:

e exists

e contains

e equals

¢ does not equal
e does not exist

4. Select the search location from the Look In drop down menu. Alternatively, click Browse to browse for
the search location.

5. Select Look in subfolders to include all subfolders in the search.
6. Select the Find 1 or Find 2 window to display results.

7. Click Find.
Results are displayed in the selected window in the Results pane.

Find markup using XPath expressions
Find markup using XPath expressions.

1. Click Edit > Find and Replace.
The Find in Files window opens.

2. Click the XPath tab.

2 Find in Files X
Text M arkup #Path
Find what:
Text || j
Look in: |><MEE ditamap ﬂ Browse...

| Look in subfolders

Optians:
fatgh caze Usze pattern matching

td atch whaole waords anly Usge regular expression matching

Results:
Find 1 resultz window

@ Find 2 results window

Find Clase Help

3. Enter a path expression in the XPath field, or select a path expression from the History drop-down list.

4. Select the search location from the Look In drop-down list. Alternatively, click Browse to browse for the
search location.

5. Select Look in subfolders to include all subfolders in the search.
6. Select the window, Find 1 or Find 2, in which you want your results displayed.

7. Click Find.
The results are displayed in the selected window in the Results pane.

Related Links
W3C Schools XPath Tutorial

Spell checking across files

You can spell check across files by using the Spell Check in Files feature. You will need to select the folder
or map file you want to spell check.
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Replacing results across files

To do this:

1.

w

o

Click Tools > Spell Check in Files.

= Spell Check in Files [E5C

Spell Check what:

Fatal s TN Ca =<1 E B dliEarnap - Browse...

Include subfolders

Output optiohs

[T] Show markup attibutes Show suggestions Fast spell check

[ 5pell Check ‘ [ Close ‘ [ Help

.

Enter the name of the folder or map file you want to spell check.
Select the 'include subfolders' check box to spell check content in all subfolders.
Select from any of the following output options:

» Show markup attributes - Displays markup attributes in the results

e Show suggestions - Displays replacement options for correct spelling with the results. Tapping on a
replacement option inserts it in place of the original text

 Fast spell check - The spell check does not load the DTD or XSD for each XML document being spell
checked.

NOTE: If your documents have DTD-inferred attributes such as xml:lang="fr-FR", you may get the wrong
dictionary applied during the spell check when using Fast Spell Check.
Click Spell Check to perform the spell check across files.

Results are displayed in a tab in the Results pane.

~ Note: The Spell Check in Files feature will not differentiate between markup and text.

Replacing results across files
After you have performed a cross-file search or spell check, you can replace any or all of the results.

1.

In the Results pane, select the check boxes of the results you want to replace, OR click the Check all
items button ( )to select all results.

=

e

" Note: You can click Uncheck all items ( 0 ) to clear all check boxes.

In the Replace with: field, enter the replacement text or markup.

3. (optional) Click the Set Replacement Options button (&1) to set replacement options. For instructions,

90

see Setting replacement options on page 91.
Click the Replace all checked items button ( APPl¥ to B ) to replace only the items you have checked,
OR click the Replace all highlighted items button ( Apply to highlighted

User's Guide



Setting replacement options

After you have replaced text or markup, you can click the New search in checked files button (), or press
F7, to perform a new search on the already searched files for which results are displayed in the current tab
of the Results pane.

Setting replacement options

1.

In the Results pane, click the Set replacement options button ().
The Replace Options dialog appears.

In the General section, set the following:

* Open files - when a replacement is performed, the affected file is opened. When Open files is checked,
you can perform undo operations for each open file to undo text replaced using the 'Replace with' feature.

e Track changes - all changes made by the replacement operation will be displayed

« Make backup files - Create backup files. if you chose to make backup files, enter the default file extension
for the backup files.

In the Replace All Checked Options section, set the following parameters:

« Don't redo prior replacement even if checked - if an identical replacement operation has been performed
on a checked field, it will not be repeated even if that file is again checked

« Uncheck items after replacement - the results that are checked will be unchecked after the replacement
operation has finished

In the Interpret-as-markup strictness section, select one of the following options:

« Full - checks the markup compatibility of the replacement value and the location into which it is inserted
as well as its children

e Partial - checks the markup compatibility of the replacement value and the location into which it is
inserted

¢ None - markup is not checked

Click OK.
The new settings now apply to all future replace actions in the Results pane.

Running cross-file operations

The Run Cross-File Operation feature allows you to run other cross-file operations that may have developed
specifically for your needs.

To do this Follow these steps

Run cross-file operation Click Tools > Run Cross-File Operation

The Run Cross-File Operation feature allows you to run the chosen cross-file operations:

» Accept All Changes - accepts all the changes tracked in the selected folder or given set of files

Detect Duplicate IDs - looks for duplicate attribute values for specific attribute type within each document

« Validate References - validates all the cross references by asserting if the file is present or not; it will report

any broken links

« Word Count - counts the words in each file and report the number of words in each file and the total number

of words

You can apply the cross-file operation to any of the following:

« All Open Documents - searches all documents (topic and map files) that are currently open

Current Document - searches the topic file you have currently open
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Cross-file operations

« [currently active map file] - searches all files in the currently active map file in the Map Editor (the name of
the map is displayed in the drop-down list)

 You can also click Browse to select a specific folder on which to run the cross-file operation. The cross-file
operation will apply to all files in the folder (and subfolders, if the Include subfolders check box is selected).

= Run Cross-File Operation |’ S|

Fur what:

Dperatior: | e

Description: |For each <ML document, all =Metal track changes will be accepted. =

fpplyto:  [WMEE diamap ~|  Browse..

Include subfalders

Run ‘ Cloze ‘ Help |

Cross-file operations
Cross-file operations provide searching, spell checking and other operations across multiple files in a folder
or references from a ditamap.

Cross-file operations can be limited to a defined set of files. By default, xml, sgml, sgm, dita, and ditamap file
types are selected.

To set cross-file operation preferences:
1. Select Tools > Options from the main menu.

The Options dialog box opens.

2. Under Cross-File Operations, select General to add or remove file types whose processing you want to
limit.
3. You can optionally choose to include or exclude attributes from the DTD.

p

—~/ Note: Selecting this check box causes cross-file operations to run slower.

4. Click OK to save changes.

Results pane

92

The Results pane displays the results of cross-file operations, such as the Find in Files feature, and
error-reporting features, such as the Validation Log.

To do this Follow these steps

Show Validation log Click View > Results > Validation
Show Xlinclude link errors log Click View > Results > XiInclude

Show Find 1 results Click View > Results > Find 1

Show Find 2 results Click View > Results > Find 2

Show Spell Checking results Click View > Results > Spell Checking
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Results pane

To do this Follow these steps

Show Reference Checking Click View > Results > Reference Checking
Show Topic References Click View > Results > Topic References
Show Key References Click View > Results > Key References
Show Cross-File Operation results Click View > Results > Cross-File Operation

Results for the following features will be displayed in the Results pane:

 Validation - Lists markup errors

reslls 1

& [rpled migeng end-tag /b

 Xinclude - Displays XML inclusion link errors

H
W 1 the Xinclade “parse™ stirbube i set b “ui™, then oo or both of the Threl™ and “peorvier” sitrbubes must be set. LinkInk: [, son) PareniLocation: {{-1, } Untsed 1}
q I »
B Yinckue |

e Find 1 and 2 - Lists search results for the Find in Files feature
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Results pane

94

Results *x
t 8 By E B F X x

Find in result: | tl A By

Replace with: | I:I

<> | [ E Apply to & Apply to highlighted

E4

--|7|_j AboutWorldTimePro.xml { 14 items ) E’

--l_l_j CalculatingElapsedTime.xml { 26 items )

E||7L_":-' CalculatingHoursinMinutesSeconds.xml { 2 items )

M [LWorld Time Pro...

“M o world Time Pro...

IZ—ZI|_L_":-' CalculatingTime.xml { 12 items )

- L.Calculating time...
=~ L.world Time Pro...

=0 time.

=~ .world Time Pro...

=~ L.world Time Pro... vl
<] - - = T l . . B
Find 1

« Spell Checking - Lists all spelling errors

DR CAERER = Aty oy x
B L_’i Results_pane.dita ( 1 ermors )
E ... the topics of this ditamap...
B Summary:
Spelling error(s): 1 In file(s): 1 Spell-checked files: 4
Options:

Look in|211 Cpen Documents

Spell Checking

» Cross-File Operation - Lists results for the Run Cross-File Operation feature

e Accept All Changes - For each XML document, all XMetaL track changes will be accepted

« Detect Duplicate Ids - Look for duplicate occurrences of ID attribute values within each document
» Validate Cross References - For each XML document, check for broken references

¢ Word Count - Count all the words in all the topics of this ditamap

» Reference Checking - Checks the status of references

T -
B 3 & S
=y Update References Type Configurations:

oonrel: | brue confel_include_image-  rue conrel recursive: | falsa xraffnelated-links: | Fakaa keyrel: | ire
topicred;  nae topicref with @ikeys: | false mapred;  imse mapref with fkeys: | Eise

8 Pecference Checking
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Results pane actions

» Topic References - List results for Find References to Topic

T 3 EyE:E(H O Gy x

=3 Summary:
Matching itemis). 0 Malching file{s): 0 Files searched: 199
Capit s
Apply f/* [concains (Ahref, 'concepoa/Fanes.dica’) or concains
rarkug [Anzes, 'Cr\users_guide\src\concepraiPanes.dita') or comrains (doonzef, 'concepra/Fanes.dita') or
filbgr contains (Bconzes, 'Oy uFess_gu ideharc\concepra\Fanes . diTa")]

Look in C:"-.'.':frs_l:u'_de"a.::c"-.}:‘IE.d'_:am:

| % Topuc References

« Key References - Lists results for Find References to Keys

T 3 B, E: B W Gy x

- Panaes.dita { 1 tems )
<harm keyref="resullipane™ clasa="- lopic'bemm "=

- FEsUIS....

= & Summary!
Matching item(s); 1 Malching file(s): 1 Files searchid: 199
Orptions:
Apply markup filter // * [contains ifkeyret, "seaulcpane"} or contcains (Bconkeyrel, "resultpanes')]
Lok in Crhusers_guide’src\iHEE.dica=sp

B8y Ky References

Related Links
Panes on page 14

Panes provide access to the markup in your document and let you organize resources. You can
have one or more panes open in your work area at any time. You can dock a pane so that it is
attached to the work area border, or the pane can float. You can pin a pane to keep it open, or un-pin

a pane to hide it.

Results pane actions

A list of actions, including the their button, name, and description. Most of the features will have similar actions,

such as previous and next.

Table 33: Common actions

Button Name Description
Previous Select the previous location in
T the results list (Shortcut:
Shift+F4)
Next Select the next location in the
3 results list (Shortcut: F4)
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Results pane actions
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Button

Name

Wrap

Switch View

Expand All

Collapse All

Find in result

Replace with

Find previous

phrase

Find next
phrase

Close Tab

Description

Toggle line wrapping (applies
to list view only)

Switch view (tree versus list)

Expand all the results to
display in a tree view

Collapse all the results to
display in a folder view

Text to search for amongst
result items

Text to replace searched for
result

Find previous occurrence of the
phrase

Find next occurrence of phrase

Close results

Table 34: Actions specific to Find in Files

Button Name Description

Toggle Highlight all results in the active

o5 highlighting document

w Remove Remove results that are
selected highlighted and that have their
item(s) from | check boxes selected
results

B Set Open the Replace Options
replacement | dialog to set replacement
options options
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Text case assistant

Button

EE

0oa

>

Apply to

Ll
‘II-

Apply to highlighted

Name

Check all
items

Uncheck all
items

Replace as
markup

Replace
highlighted
text

Replace all
checked items

New search in
checked files

Description

Select all check boxes
Unselect all check boxes

Denote that the replacement
you are using is an element

Replace all results that are
highlighted with the text from
the Replace With text field

Replace all results that are
checked with the text from the
Replace With text field

Perform a new search only
in the files that you have
checked and for which
results are displayed in the
current tab of the Results
pane. (Shortcut: F7)

Table 35: Actions specific to Spell Check in Files

Button Name Description
@ Add to Add the word to the dictionary
dictionary
= Re-check Re-check spelling in those files
found files only in which spelling errors
only were found in the initial spell
check (Keyboard shortcut: F7)
Show Spell Show spell checker after
Checker jumping to result
v
Toggle Highlight all results in the active
o 5 Highlighting document
Apply to highlighted Replace Replace all results that are
highlighted highlighted with the text from
text the Replace With text field
| Set Open the Replace Options
replacement | dialog to set replacement
options options

Text case assistant

The text case assistant provides text casing adjustment options for selected text.
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Working with Markdown documents

To change text case, select the text for which you want to change the case, and then either click Ctrl + F3
(by default) or right-click to open the context menu and select Text Case and one of the available options.
The options are:

« Sentence case. - only the first letter of the sentence is in upper case when a full stop is included in the
selection

« lowercase - all letters in the selection are displayed in lower case

« UPPER CASE - every letter in the selection is capitalized

 Capitalize Each Word - the first letter of every word in the selection is capitalized

* tOGGLE cASE - the case is inverted for each word in the selection

=

2 Note: The tOGGLE cASE option is only available in the right-click menu and not when using Ctrl + F3.

To set text case assistant preferences:

1. Select Tools > Options from the main menu.
The Options dialog box opens.

2. UnderAssistants, selectText Case.
3. In the Display section,

» select Show in context menu to include the text case assistant in the right-click menu or select, or
« select Show in Format toolbar to display the text assistant in the Formatting toolbar.

e

“ Note: For this change to take effect, a system restart is required.

4. The trigger is, by default, Ctrl + F3. This trigger key can be edited in the Trigger section by selecting a
keyboard trigger from the list.

5. Click OK to save changes.

Working with Markdown documents

XMetal supports the Markdown syntax and provides an easy to use split-screen editor. You can write
documents in Markdown as well as convert documents into Markdown and convert Markdown documents
into HTML and MS Word Document.

When editing a Markdown document, the editor has two panels. The Markdown syntax is highlighted in the
editor's left pane.GitHub Flavored Markdown (which is a strict superset of CommonMark) rules are used. The
right side is a web preview that is synchronized in real-time. For reference, see the remote-components topic
in the Remote Lighting (LwDita) sample document in Help > Samples.

The Markdown document can be converted to HTML and MS Word Document.
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Working with Markdown documents

: File Edit View Insert Tools Table Repository Window Help

NEEHS AAEAT Sl 9 @S] - @ @S EM

remote-components.md . Working_with_Markdown_documents.dita

1i——-
2 id: remote-components
| -

a

s # Remote Control Component:
4]
7 The remote control of your [product-i
&
9 I[Front and back of remote control](

| Component

I

| Power button indicator

| Power butten

| Dimmer control

| Lighting group number indica
| Group number button

| 411 group numbers

| Battery compartment

| Reset button

: If you reset the remote contro

BIUS - HIHZHIHIHS HG | {} " — o 2 =@ !‘PEH i [P

" Remote Control
Components

The remote control of your [product-name] has
components that allow you to program and
operate the light bulbs on yvour lighting network.

)
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Authoring structured content

When you create a document instance of a DTD or Schema in Normal or Tags On view, XMetalL Author
ensures that your content is valid by guiding you through the authoring process. You do not need to have a
complete understanding of XML to begin authoring structured content.

Here are some of the ways in which XMetalL Author helps you create documents that conform to a DTD or
Schema:

The Element List displays only elements that are valid at the current element. Required elements are
displayed in bold.

The Attribute Inspector displays the attributes for the current element. Attributes that require a value are
displayed in bold.

Commands and menu items are unavailable if using them would result in an invalid document.

You are prevented from typing text in the current location if the DTD or Schema does not allow it. If you
type at a location where text is not allowed, text is wrapped in the first valid paragraph element (if available).
You are prevented from deleting an element if it is required by the DTD or Schema.

You are prevented from inserting a CDATA section or other marked section that would result in an invalid
document.

You are prevented from pasting elements or text at an invalid location. The Smart Insert feature inserts
them at the next valid location in the document or the paste operation is not completed.

You are prevented from dropping assets from the Resource Manager at an invalid location. The Smart
Insert feature inserts them at the next valid location in the document or the paste operation is hot completed.
You are prevented from inserting elements at an invalid location. The Smart Insert feature inserts them at
the next valid location in the document.

When working with change tracking, you cannot reject a change that is necessary to make the document
valid.

When using Find and Replace, you cannot make an element replacement that would make the document
invalid.

You are prevented from applying a condition on elements that are required by your DTD or Schema.

Related Links

Appendix A: XML basics on page 251
XML (Extensible Markup Language) is a recommendation of the World Wide Web Consortium (W3C).
It is a language for describing the structure and content of a document. Authors use XML to “mark
up” their documents for a consuming application such as a Web browser or print formatting engine.
XML is an application of SGML (Standard Generalized Markup Language). XML is more flexible
than other markup languages such as HTML because it allows you to create your own markup. This
makes it better suited to describing and processing complex information.

Validation and rules checking

Validation checks to see if the markup is correct and complete with reference to your DTD or Schema. Rules
checking ensures that you do not break the required structure as you edit your document by allowing you to
insert only valid elements.
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Validation using Schematron

To do this Follow these steps

Validate a document Click Tools > Validate Document

Validation occurs automatically when you save your document or when you switch from Plain Text view to
Normal or Tags On view. You can validate an entire document, or you can select a selection of your document
to validate. Errors are displayed in the Validation Log.

Validation checks that the following conditions have been met:

 All elements, attributes, and entities used in the document have been declared.

* All required elements are present.

« All required attributes are present.

« All attributes are in the correct form.

« All I Dattribute values are unique, and each | DREF attribute value matches an | D attribute value.

Rules checking is less stringent than validation in that it checks that no errors have been made, but does not
check that the markup is complete. For example, rules checking does not check required elements, undeclared
entities, or missing 1D values.

Rules checking occurs in Normal and Tags On views only.

Rules Checking On

Validation using Schematron

The Schematron differs in basic concept from other schema languages in that it not based on grammars but
on finding tree patterns in the parsed document. This approach allows many kinds of structures to be
represented which are inconvenient and difficult in grammar-based schema languages.

NOTE: XMetaL now supports XSLT 2.0 for Schematron validation using Saxon-CE version 1.1. Saxon-CE
implements XSLT 2.0 at a minimum conformance level meaning itis a "Basic XSLT 2.0 Processor" as defined
by the W3C XSLT 2.0 Specification.

To validate using the Schematron:

1. From the Tools menu, select Validate using Schematron (or hit CTRL + F9).

2. In the Schematron results pane, user the drop-down list to select a Schematron file to apply, and then
click the Schematroll button to run the validatation.

3. You can also adjust the Schematron processing settings by going to the unified Options pane and clicking
on the Tools > Schematron option.

For more information on Schematron validation, see http://schematron.com/.

Schematron Options
You can control options for global parameters, processing and debugging in the Tools > Schematronsection
of the Options dialog box.

Table 36: Global Parameters

Option Description

Pass through non-Schematron elements Please refer to http://www.schematron.com for more details.
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Schematron Options

102

Option Description
Add diagnostics to assertion results

Generate XPath values for SVRL @location attributes
Table 37: Schematron Processing

Option Description

Run Document Schema Definition Languages (DSDL)
phase

Run Abstract Patterns expansion phase

Run custom SVRL to HTML results stylesheet

Table 38: Debugging Options

Please refer to http://www.schematron.com for more details.

Option

Description

Use debug version of Saxon-CE

Logging Level

The debug version of Saxon-CE provides error and event
logging capabilities with a configurable logging threshold.

For definitions of the logging levels, see
http://www.saxonica.com/ce/user-
doc/1.1/html/coding/logging.html

The default logging level is set to SEVERE.
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XMetal customizations

F

Options

et F— = E

Search Options (Ctrl+F)

View
Plain Text View
File
Change Tracking
Windows and Tabs
Assistants
Symbels
QuickMarkup
Text Case
Cross-File Operations
General
Replace
DITA
General
Update Content
Map Editor
Key Space
Subject Scheme
Specializations
DITA Output
Deliverable Type
Preview
Advanced
Tools
3rd Party Viewers

m

Global Parameters

Pass through non-Schematron elements (@llow-foreign=false)
Add diagnostics to assertion results (diagnose=true)

Generate XPath values for SVRL @location attributes (generate-paths=true)

Schematron Processing

[] Run Document Schema Defintion Languages (DSDL) phase
Bun Abstract Pattems expansion phase

[7] Run custom SVRL to HTML results stylesheet

| Browse

Debugging Cptions
[T Use debug version of Saxon-CE

Logging Level: | SEVERE =

oK || Cancel Apply Help

XMetalL customizations

Formatting and authoring functionality are provided by an XMetalL customization. The basis for an XMetalL
customization is the DTD or Schema. Journalist is provided as an example customization. For detailed
information about creating and deploying customizations, see the XMetalL Customization Guide.

Table 39: Customization files

Name

Description

<dt dname>. ctm

<dt dname>. css

<dt dname>_structure. css
<dt dname>. t br

<dt dname>. ntr

The customization file. Contains authoring behaviors that
are based on the elements and attributes in your DTD or
Schema (for example, some keyboard shortcuts, Enter key
behavior, and mini-templates).

The style sheet for documents. Styles are based on element
names. By default, XMetaL recognizes many elements
defined in XHTML, DocBook and the Journalist DTD.

The style sheet for the structure view.
Contains toolbars and menus.

Contains macros.
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XMetal customizations

When you open a document, XMetaL searches for customization files in the following locations, in the following
order:

1. The same folder as the DTD or Schema
2. Your personal settings folder (usually Y%APPDATA% Sof t Quad\ XMet aL\ <ver si on>\)
3. The XMetalL Author installation folder (usually . . \ XMet aL <ver si on>\ Aut hor \ ) and sub-folders

If the customization file or style sheets are not found, they are created in the same folder as the DTD or
Schema.

When you work on a shared computer, you may want to save your customization files to your personal settings
folder. Customization files that are saved in your personal settings folder are not deleted when you uninstall
XMetal Author.

Journalist customization

The Journalist customization is shipped with XMetaL Author to give you an introduction to authoring structured
documents. This customization is designed to support the authoring of article-type documents. Templates
have been provided.

The Journalist customization is based on the following DTD:
..\ XMetaL <version>\ Aut hor\ Rul es\journalist.dtd
Some of the formatting and behaviors in this customization include the following:

< A mini-template consisting of an Article Title, Section 1 Title, and paragraph. Special formatting is applied
to each.

» Type atitle and press Enter. A paragraph element is inserted.

« If the selection or insertion point is inside a sequence of nested block elements, pressing Enter repeatedly
moves the insertion point up the hierarchy of nested elements.

« Follow the prompts in the replacement text that is displayed when you create an element.

« Clicking to the right of a table moves the insertion point outside of the table. This is particularly useful when
the table is at the bottom of the document.

« If you are editing a <pr e>-like element (one in which whitespace is preserved), press Enter to insert a line
break, and Shift + Enter to close the element and start a new paragraph.

 To see the context of the current element, check the context bar to the left of the horizontal scrollbar.

 Followed-by elements are defined for some elements. For example, when your cursor is positioned before
the end tag of an ordered list (</ Or der edLi st >) and you press Enter, a <Par a> element is inserted.

Related Links

104

Custom toolbars and menus on page 25
You can create new toolbars and menus and customize existing ones. You can assign buttons and
menus to built-in commands or user-defined macros.

Macros on page 45
A macro is a sequence of operations that can be run as a unit. Macros can be associated with a
shortcut key, toolbar button, or menu item. They are useful when you need to repeatedly execute a
task that does not have a built-in shortcut key or command.

Options on page 49
You can set options through the Tools menu.

Creating documents on page 53
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Working with elements

You can create a document from a template, create a blank XML or SGML document, or create a
blank, well-formed XML document. You can set file options, including a default template, filename
extensions, and autosave intervals through Tools > Options.

Images on page 110
You can insert images into your documents if your XMetaL customization recognizes elements in
your DTD or Schema as image elements, or if you are using DITA.

Working with elements

Elements are the building-blocks of your documents. They are defined in your DTD or Schema. Authoring in
Normal view is similar to applying styles, whereas Tags On view lets you work with elements as structural
objects. You can insert elements using the Element List, the Insert menu, or the In-place, look-ahead

element list.
To do this Follow these steps
Insert an element or wrap a selection in an element In the Element List, click the Insert option, select an element
and click Apply or double-click an element
Insert an element (DITA only) Click the Insert menu and select an element
Insert an inline element (DITA only) Click Insert > Inline Element and select an element type
Change an element In the Element List, click the Change option, select an
element and click Apply
Split an element Click Edit > Split Element or press Enter
Join two adjacent elements Click Edit > Join Element to Preceding
Remove tags (Unwrap an element) Click Edit > Remove Tags

Some elements include a mini-template, which contains elements and prompt text that you can replace with
your own content. For example, the <Or der edLi st > element in the Journalist customization contains a
mini-template.

o a2 9000 Digicam g

e==>gm>9hipping contents @

(=Fa8> Your Z9000 is shipped with the following contents:
..[:‘Drdara-:@_ > T

——a. [ Usten> List Item <7ahen) < Oroersais) <JSec) <Amce) 2

-~-l~-----"h-.m'"“‘"“"‘=*‘x.f4h,_ f’“‘xt_.-umfkﬂ.!“nf“"\

The current element refers to the element containing the insertion point or selection. If an entire element is
selected, the current element is the parent of that element, not the selected element itself. In Normal and
Tags On views, the context of the current element (that is, its position in the element hierarchy) is displayed
in the document status bar.
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In-place, look-ahead element list

e R e A e

J<> (=3I fEHiCIEISECﬂf

—
Para )
—

Elements are categorized as follows:

» Block elements. These elements are preceded by and followed by line breaks, such as <Par a> in the
Journalist DTD.

« Inline elements. These elements are not preceded or followed by line breaks. They are often used for
typeface modifications, such as <St r ong> and <Enphasi s> in the Journalist DTD. In some customizations,
these elements can be inserted using the Formatting toolbar.

« Empty elements. These elements cannot have any text content. They are designated by the < iconin
Normal and Tags On views. Empty elements are often used to reference images.

« Read-only elements. The content or attributes of these elements cannot be edited, for example,
<Last ModDat e> in the Journalist DTD.

Related Links
Panes on page 14
Panes provide access to the markup in your document and let you organize resources. You can
have one or more panes open in your work area at any time. You can dock a pane so that it is
attached to the work area border, or the pane can float. You can pin a pane to keep it open, or un-pin
a pane to hide it.

Toolbars on page 17
You can show/hide toolbars, create new toolbars, or modify existing ones through View > Toolbars.

Creating well-formed XML documents on page 62
When you create a blank well-formed XML document, you must define elements and attributes
before you can create content. Because the document is not based on a DTD or Schema no rules
checking or validation occurs.

Keyboard shortcuts on page 204
Shortcut keys for menu commands are indicated in the menus. All menus, menu items, and dialog
box controls are accessible by pressing the Alt key and the underlined letter (also called an access
key or mnemonic) associated with that control. XMetal Author also supports shortcut keys for window
and dialog box navigation and other functions.

In-place, look-ahead element list

The in-place, look-ahead element list is a popup list of candidate elements to insert in Normal View. You may
bring it up by pressing Ctrl+Enter.

The in-place, look-ahead element list contains elements that are valid, by default, within three containers of
the current one. The element list pane only contains valid elements for the current container.
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Editing the in-place, look-ahead element list

boolean
cite
cmdname
codeblock
codeph
concept
data
data-about ~

Editing the in-place, look-ahead element list
The display properties, insert actions, and keyboard combination for triggering the in-place, look-ahead
element list can be edited using the QuickMarkup Assistant Preferences window.

To edit the in-place, look-ahead element list:
1. Select Tools > Options from the main menu.

The Options dialog box opens.

2. Under Assistants, select QuickMarkup.
3. Inthe Display section, customize the following display properties of the list:

« Width - edit the width of the list

« Height - edit the height of the list

 Position - select whether the list appear above or below the cursor

» Depth - select the number of container levels of valid elements that are displayed
Include table elements - include table-specific elements in the list

4. In the Insert Action section, select the action to be taken when inserting an element.

< Element-only - XMetal inserts only the selected quick-insert element

» Using mini-template - XMetal inserts the element using the mini-template defined in the customization
(.ctm) file used to customize XMetal for the DTD

* With required elements - XMetal analyzes the DTD or XSD and, based on the selected quick-insert
element, inserts any additional elements that are required to make the document valid in that area of
insertion

5. In the Trigger section, customize which CTRL+ keyboard combination opens the in-place, look-ahead
element list.

6. Click OK to save changes.

Setting attribute values
You can set attribute values through the Attribute Inspector or through the Edit Properties dialog.

To do this Follow these steps
Set an attribute value for an element In the Attribute Inspector, type or select an attribute value
Set an attribute value for an element (DITA only) Click Edit > Element Properties
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Inserting and editing lists

The Attribute Inspector panel will, whenever possible, automatically suggest an attribute value if the same
attribute already has a value assigned elsewhere in the document on the same element type. This can greatly
speed up the repetitive task of assigning the same value to the same attribute throughout the document.

=/ Tip: You can select any ancestor of the current element from the list at the top of the Attribute Inspector.

Special characters in attribute values

The following characters must be escaped.

Character Escape sequence
< &lt;
> &gt;
&quot;
&apos;
& &amp;

Related Links

Panes on page 14

Panes provide access to the markup in your document and let you organize resources. You can
have one or more panes open in your work area at any time. You can dock a pane so that it is
attached to the work area border, or the pane can float. You can pin a pane to keep it open, or un-pin

a pane to hide it.
Options on page 49

You can set options through the Tools menu.

Displaying referenced content on page 161

When you open a file, referenced content is displayed according to the refresh preferences you
have set in DITA options. You can also use the menus to refresh and show referenced content.

Inserting and editing lists

You can insert lists into your documents if your XMetaL customization recognizes elements in your DTD or
Schema as list elements, or if you are using DITA.
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To do this

Follow these steps

Insert a numbered list
Insert a bulleted list

Insert a list (DITA only)
Insert a list item (DITA only)
Convert paragraphs to a list or change list type

Convert paragraphs to a list or change list type (DITA
only)

Increase list indentation (DITA only)

Decrease list indentation (DITA only)

i
Click #= (Numbered List) on the Formatting toolbar

Click = (Bulleted List) on the Formatting toolbar
Click Insert > List and select a list type

Position the cursor in a list and click Insert > List Item

i— -—
Select one or more paragraphs and click ¥= or i=

Select one or more paragraphs, click Paragraph >
Apply/Remove Bullets or Apply/Remove Numbering

Position the cursor in a list item and click Paragraph > Increase
List Indentation

Position the cursor in a list item and click Paragraph > Decrease
List Indentation
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Sort a list

To do this Follow these steps

Split a list (DITA only) Position the cursor in a listitem and click Paragraph > Split List

Table 40: Keyboard shortcuts

To do this Follow these steps

Insert a list item Position the cursor in a list item and press Enter (press
Enter twice if the contents are surrounded by a sub-element
such as a paragraph)

Insert a list within a list Insert a list item and press Tab

Convert list items to a nested list Select one or more list items and press Tab

Convert list items to paragraphs Select one or more list items and press Shift+Tab

Demote one or more items to a sub-list Position the cursor in a list item and press Tab

Promote a sub-list up one level to its containing list Position the cursor in a list item and press Shift+Tab
Terminate a list Position the cursor in a list item and press Enter twice (once

if you are already in an empty list item and three times if
the list item contents are surrounded by a sub-element)

2 Tip: You may find Tags On view preferable when working with lists.

If your DTD or Schema declares the HTML <UL> or <OL> elements, XMetalL Author recognizes them as list
elements. Your DTD should also declare the <LI > (list item) element. The Journalist DTD declares the
<Item zedLi st > and <Or der edLi st > elements.

Definition lists consist of pairs of terms and definitions. You can use definition lists for any purpose that is
suited to two-part lists. The <Vari abl eLi st > element in the Journalist DTD is an example of a definition
list:

<Vari abl eLi st > <VarLi stEntry>

<Ter mpTer mL</ Ter m> <ListltenmpDefinitionl</Listltenmr

</ Var Li st Entry> <VarLi st Entry> <Ter n>Ter n2</ Ter n»

<ListltenrDefinition2</Listltenr </VarlListEntry>
</ Vari abl eLi st >

Sort a list
You can sort an entire list, or selected list items in a list.

1. (optional) If you only want to sort certain list items, highlight the items you want sorted in the list.
2. Click Edit > Sort.
The Sort List dialog box opens.
3. If you selected list items to sort in step 1, select to sort either Selected Iltems or the Entire List.
4. In the Type field, select to sort by one of the following:
» Text - sorts columns in order, alphabetically and by numerical value
« Number - sorts columns in order by number. Sorting pays only attention to numerical values, and entries
beginning with letters are not sorted and instead appear at the beginning or end of the range depending

on your sorting direction.
« Natural - sorts values in a natural order, numerically and alphabetically

» Date - sorts values by date

5. Select either Ascending or Descending sorting direction.
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Images

6. Click OK.
The list is sorted.

Images

You can insert images into your documents if your XMetalL customization recognizes elements in your DTD
or Schema as image elements, or if you are using DITA.

To do this Follow these steps
Insert an image Click Insert > Image and select an image.
-OR -

Drag and drop an image (from within or outside
XMetal) to where you want to place it. It will be
automatically placed in an image element.

File navigation options are available in the Choose
Image File dialog as follows:

« Show Folder - displays the folder for a selected file
to allows users to navigate to the folder where the
image is located.

* Find all files in folders - allows users to view all
files in a selected directory, including sub-folders,
in one list. The file extensions filter allows, including
sub-folders, to narrow down list of file specific types.

< A powerful file preview feature.

Insert a figure with a title (DITA only) Click Insert > Figure with Title and select an image

Insert an image represented by an entity Insert an image element using the Element List, then specify
the entity name as the value of the source attribute (or
attribute that represents the image file)

Edit image properties (DITA only) Select an image and click Edit > Element Properties

If your DTD or Schema declares the HTML <l MG> element, XMetal Author recognizes it as an image element.
Your DTD should also declare the following attributes of the <I M5> element: SRC, ALT, HEl GHT, and W DTH.
The Journalist DTD declares the <G aphi ¢> and <I nl i neG aphi ¢c> elements.

DITA images

DITA declares the <i mage> and <f i g> elements. The <f i g> element has <ti t | e> and <i mage> child
elements. You can use this element to insert an image with a caption, for example:

<fig> <title>Wy sunmmer getaway</title>

<i mage href="../images/LakeCharl es.jpg" placenent="break" w dth="300px">
<I-- alternative text (if specified) is saved in the alt elenent -->

<al t >Lake Charles in sumer</alt> </imge>

</fig>

Table 41: Image properties

Property Attribute/element Description

File hr ef The relative path or URL to the image.
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Supported display formats

Property Attribute/element
Alt text <alt>

Text wrapping pl acenent
Horizontal alignment align

Width wi dt h

Height hei ght

Units N/A

Scale scal e

Description

Provides a text description when an
image cannot be displayed by the
user’s software. (If the <al t > element
does not exist, the contents of the al t
attribute are displayed.)

Indicates whether an image should be
displayed inline or separated from the
surrounding text. The default is ‘inline’.

Controls the horizontal alignment of an
image when placement is specified as
‘break’.

Indicates the horizontal dimension for
the resulting image display. (If you
specify an absolute size for the image,
the aspect ratio is maintained unless
you enter both a width and a height.)

Indicates the vertical dimension for the
resulting image display.
The unit of measurement when a width

and/or height is specified.

Specifies a percentage by which to
scale the image in the absence of any
specified image height or width.

Related Links
Assets (unsupported) on page 44

You can organize frequently used objects as assets through the Resource Manager. Assets can be
single files, such as images, text, or markup blocks. You can drag and drop assets into your document.

XMetal customizations on page 103

Formatting and authoring functionality are provided by an XMetalL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetal Customization

Guide.

Supported display formats
XMetal Author can display several image formats.

@ . . . .
"~ Note: To see which formats are supported in output, check the documentation for the DITA Open Toolkit.

Table 42: Supported display formats

© 2023 JustSystems Canada, Inc.

Name File extension Notes

Windows Bitmap BMP Only the Windows BMP format is
supported.

Encapsulated PostScript EPS EPS files must contain an embedded
TIFF header.

Graphic Interchange Format GIF Only the firstimage in an animated GIF

(Compuserve) is displayed.
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Tables

Name File extension Notes

Joint Photographic Experts Group JPG (or JPEG, JPE, JFIF, JIF)

Windows Icon ICO

Windows Metafile WMF WMF files must include a placeable
header.

Enhanced Metafile EMF

Portable Network Graphics PNG

Tagged Image File Format TIF (or TIFF) Only the first image in a file containing
multiple images is displayed.

PC Paintbrush PCX

Truevision Graphics Adapter or TARGA | TGA

Scalable Vector Graphics SVG Requires installation of an SVG viewer
(for example, Adobe SVG Viewer).

Related Links
Options on page 49
You can set options through the Tools menu.

Tables

XMetalL Author supports the HTML and CALS table models. If your DTD or Schema uses either of these
models, you can use the Table menu to insert and edit tables.

€ Note: XMetal Author does not support both table models in the same DTD or Schema.

Insert Table (|
Rows: H = Columns: 2 =
Background color:

Table width: 2] @ Porcent
() Pixels
Border
@ Grid —
_ == Width: 1 b
() None o b I
Cell spacing: z [ Insert Header
Cell padding: = [ Insert Footer
OK | | Cancel | | Heb

Appropriately formatted content from other applications can be pasted or dragged and dropped into an XMetalL
document as a table.
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Tables

You can choose to display or hide table grid lines for tables that do not have set borders through the View

menu.

Navigating within tables

Here are some convenient ways to navigate between table cells:

« To move between cells, press an arrow key
« To move to the next cell in a row, press Tab
» To move to the previous cell in a row, press Shift+Tab

Working with tables in DITA documents

If you are working in a DITA document, you can insert a CALS table, a simplified version of the CALS table,

or a topic-specific table. Choose from the following:

« Normal table. The default CALS-based table model. Provides extensive control of display and structure.
» Properties table. For use in Reference topics. Gives a list of properties for the subject of the current topic.

« Simple table. A simplified version of a Normal table that allows fewer elements and less control over display.

* Choice table. For use in Task topics.

Insert Table
Table Type: |Mormal Table -
Number of rows: = = Insert Header

Number of columns: 2

Border

oK l | Cancel | |

Help

Related Links
Keyboard shortcuts on page 204

Shortcut keys for menu commands are indicated in the menus. All menus, menu items, and dialog
box controls are accessible by pressing the Alt key and the underlined letter (also called an access
key or mnemonic) associated with that control. XMetal Author also supports shortcut keys for window

and dialog box navigation and other functions.
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HTML tables

114

HTML tables
If your DTD or Schema declares the <TR> and <TD> elements, XMetaL Author assumes the HTML table
model.

HTML tables consist of rows and cells. Table rows (as denoted by <TR> elements) may be grouped into
header, footer, and body sections (<THEAD>, <TFOOT>, and <TBQODY>). Table cells may contain header-type
or data-type information (<TH> or <TD>).

Here is an example of an HTML table:

<TABLE><CAPTI ON>Li ve births,

Feb to Mar</ CAPTI ON> <THEAD>
<TR><TH>Gender </ TH><TH>Nunber </ TH><TH>%/ TH></ TR>
</ THEAD> <TBODY>
<TR><TD>Femal e</ TD><TD>62</ TD><TD>50. 8</ TD></ TR>
<TR><TD>Mal e</ TD><TD>60</ TD><TD>49. 2</ TD></ TR>

</ TBODY> </ TABLE>

CALS tables
If your DTD or Schema declares the <t gr oup> element, or if you are working in a DITA document, XMetalL
Author assumes the CALS table model. XMetaL supports a definition of the CALS DTD developed by OASIS.

CALS tables contain the <t gr oup> grouping element. <t gr oup> elements contain a table header, table
body, and table footer (as denoted by <t head>, <t body>, and <t f oot > elements, respectively). Headers
and footers are optional. You can insert a header when you insert the table, or you can change the row type
(for example, change a body row to a header row) through the Row tab of the Table Properties dialog.

You can insert a CALS table with a maximum of 150 rows and 150 columns. If you need more, you can add
them after you create the table.

Here is an example of a CALS table:

<tabl e><title>Live births, Feb to

Mar</title> <tgroup col s="3"> <thead>

<row><ent ry>Gender </ ent r y><ent r y>Nunber </ ent r y><ent r y>%/ ent r y></ r ow>
</t head> <t body>

<row><entry>Femal e</ entry><entry>62</ ent ry><ent r y>50. 8</ entry></r ow>
<r ow><ent r y>Mal e</ ent r y><ent r y>60</ ent r y><ent r y>49. 2</ ent r y></ r ow>
</tbody> </tgroup> </tabl e>

Inserting and editing tables

You can insert and edit tables from the Table menu. When you insert a table, you specify basic table layout
including the number of rows and columns. You can add or remove rows or columns and split or merge cells
in a table. These operations affect the table structure.

When editing tables, the auto-suggest table cell feature will, whenever possible, automatically suggest a text
value for a table cell. This can greatly speed up the repetitive task of filling in table column values throughout
the document.
Insert a table

-

“ Note: If you are working in a DITA topic and you are prevented from inserting the type of table that you
select, it is because the topic type does not allow it.

If you are working in a DITA topic, you can restore the structure of a simple table, properties table, or step
choices table (for example, after backspacing and removing a cell) by clicking Table > Repair Table Structure.
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Insert a cell, row, or column

1. Place the cursor in the location you want to insert the table.

2. Click Table > Insert Table.
The Insert Table window opens.

3. Select a table type (CALS only).
4. Select the number of rows and columns in the table.

5. Click OK.
The table is inserted into the selected location.

To add a caption:

E

2 Note: For HTML tables only
1. Place the cursor in the table.

2. Click Table > Insert Caption

Insert a cell, row, or column

Insert a cell
You can add a cell by splitting an existing cell into two rows or columns.

1. Place the cursor in a table.
2. Click Table > Split Cell Into Columns or Split Cell Into Rows

Insert a row
1. Place the cursor in a table.
2. Click Table > Insert Rows or Columns

E . .
>/ Note: To add a row to at the bottom of a table, you can also place the cursor in the last cell in a table
and press the Tab key.

Insert a column

1. Place the cursor in a table.
2. Click Table > Insert Rows or Columns

Edit a cell, row, or column

Move a row or column

1. Place the cursor in a row or column.
2. Click Table > Move Row or Column.

The Move Row or Column dialog opens.

3. Choose an option.

4. Click Apply to apply the action and continue with more actions, or click OK to apply the action and close
the dialog.

Move a cell

You can move cells by cutting (or copying) and pasting them.

1. Select a block of cells.
2. Click Edit > Cut (Copy).
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Delete a cell, row, or column

3. Place the cursor in the location you want to paste the cells.
4. Click Edit > Paste.

.
=/ Tip: You can copy your selection by holding down the Ctrl key while you drag and drop the selected

block of cells to its new location.

J Note: You can use the cut (copy) and paste operations to re-position a selected block of table cells.
However, the paste location must have the same configuration as the block of cells you are cutting. If
you are cutting and pasting between tables in different documents, both documents must use the same
DTD or Schema. Content in the target cell block is overwritten with the pasted content.

Merge cells

1. Place the cursorin a cell.
2. Click Table > Merge cell.

The Merge Cell dialog opens.

3. Select a merge option.

4. Click Apply to apply the action and continue with more actions, or click OK to apply the action and close
the dialog.

Contract a cell

If a cell spans two or more rows or columns, you can contract it to the proportions of the adjacent rows or
columns.

1. Place the cursor in the cell that spans two or more rows or columns.
2. On the Table Advanced toolbar, click one of the following options:

e Contract Cell from Left

» Contract Cell from Right

e Contract Cell from Bottom
« Contract Cell from Top

3. The cell is split, and the border is aligned with adjacent borders.

Delete a cell, row, or column

Delete a cell
You can add a cell by merging it with another existing cell.

1. Place the cursor in a table.
2. Click Table > Merge Cell.

Insert a row
& . .
2 Note: The row is deleted without a prompt.

1. Place the cursor in a table.
2. Click Table > Delete Row.

-
=/ Note: To add a row to at the bottom of a table, you can also place the cursor in the last cell in a table
and press the Tab key.
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Copy acell

-OR-

1. Select the entire row of a table.
2. Press the Shift key and the Right Arrow key.

The row is highlighted blue.
3. Press the Delete key.

Delete multiple rows

1. Select the entire rows that you want to delete.
2. Press the Shift key and the Right Arrow key.

The rows are highlighted blue.
3. Press the Delete key.

Delete a single column

E . .

"2 Note: The column is deleted without a prompt.
1. Place the cursor in a table.

2. Click Table > Delete Column

Copy acell
The contents of a table cell can be quickly copied to other selected cells in the same table.

1. Beginning the cell from which you want to copy content, select all the cells which you want to include the
same content of that initial cell.

2. Select Table > Copy Cells.
The content is copied to all selected cells.

& . . . .
"2 Note: If any of the other cells contain content, it will be overwritten by the copied content.

Fill series of table cells

A cell with numerical content can be used to create a numerical series in a table. The content of the anchor
cell that is being used to initiate the series must be a number (e.g., 123) or end in a number (e.g.,
loremipsum123). The series proceeds left to right, top to bottom in the table. The series affects whole numbers
only so, for example, an initial value of 1.9 creates a series with values 1.9, 2.9, 3.9, and so on.

1. Enter the initial value in the anchor cell.
J Note: The anchor cell must be the top left cell in the table.

2. Select the cell(s) for which you want to fill the numerical series, starting with the anchor cell.
J Note: If any of the other cells contain text content, it will be overwritten by the series.

3. Select Table > Fill Series.

The series is displayed in selected cells in the table.

Fill cell attributes

Cell attributes can be copied from an anchor cell to other cells in the table in one operation. The anchor cell
is the cell in which you start a multi-cell selection.

1. Select the cell(s) for which you want to fill cell attributes, starting with the anchor cell.
2. Select Table > Fill Cell Attributes.
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Split a table

The Select Table Cell Attributes dialog opens.
Select Table Cell Attributes (o)

Display Order

- entry

[ colname coll _) Ascending
] id 12345
[ translate no
[ align @) Spedfied Attributes First
[] base

[] char

[ charoff
[ colsep
|:| conaction
[ conkeyref
[ conref
[] conrefend I Selected Attributes First I
[ dir
[] morenows I Select Al I
[ nameend
[T] namest I Select Mone I
[ outputclass
[ rev - I Invert Selection I

" Descending

m

Ok ] I Cancel I l Help I

3. Select the check boxes for the attributes you want to copy to the other cells, or click Select All to select
all attributes.

4. Select the display order:

< Ascending - alphabetical order
« Descending - reverse alphabetical order

» Specified Attributes First - Displays the attributes with content first in alphabetical order, and then all
empty attribute sin alphabetical order

5. (optional) After you have made selections, you can click Selected Attributes First to bring all selected
attributes to the top of the list.

6. (optional) Click Select None to remove all selections, or click Invert Selection to select all unselected
attributes, and unselect all currently selected attributes.

7. Click OK to apply all changes.

Split a table
CALS and custom tables can be split into two or more individual tables at the table element level.

1. Place the cursor in the table you want to split.

2. Click Table > Split Table to split above the cursor location or Table > Split Table (Below) to split a table
below the cursor location.
The table is split into two tables immediately above or below the row where the cursor is located. The split
location is identified by dotted lines in both tables.

Related Links
Merge a table on page 119
Tables that have been split from each other can be merged back into one table.

CALS tables on page 114
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Split a table group

If your DTD or Schema declares the <t gr oup> element, or if you are working in a DITA document,
XMetal Author assumes the CALS table model. XMetaL supports a definition of the CALS DTD
developed by OASIS.

Split atable group
CALS and custom tables can be split into two or more individual table group at the tgroup element level.

1.
2.

Place the cursor where you want to split the table (either above or below the cursor).

Click Table > Split Table Group to split above the cursor location or Table > Split Table Group (Below)
to split a table below the cursor location.

The table is split into two tables immediately above or below the row where the cursor is located. The split
location is identified by dotted lines in both tables.

Related Links

Merge a table on page 119
Tables that have been split from each other can be merged back into one table.

CALS tables on page 114
If your DTD or Schema declares the <t gr oup> element, or if you are working in a DITA document,
XMetaL Author assumes the CALS table model. XMetaL supports a definition of the CALS DTD
developed by OASIS.

Merge a table
Tables that have been split from each other can be merged back into one table.

1.
2.

Place the cursor in the table you want to merge.
Click Table > Merge Table (Below) if the split is below the cursor location, or click Table > Merge Table
if the split is above the cursor location.

Related Links

Sort a table on page 119
You can sort tables, or selected rows in a table. Sorting is available for HTML and CALS tables as
well as custom table models.

Sort atable
You can sort tables, or selected rows in a table. Sorting is available for HTML and CALS tables as well as
custom table models.

1.
2.

(optional) If you only want to sort certain rows, highlight the rows you want sorted in the table.

Place the cursor in the table, and then select Table > Sort....

The Sort dialog box opens.

(If you selected rows to sort in step 1) In the Scope section, select to sort either Selected Rows or the
Entire Table.

Select the @colname check box to view the columns by the @colname tag. Otherwise, the columns will
be identified by number and text content.

In the Sort By section, select the sort type from the available options (as below), and then select either
Ascending or Descending and Case Sensitive or Case Insensitive.

Note: Although the attribute colname can be changed in the <entry> element in the table, the name of the
column is not changed and it is the same as specified in the <colspec> element. That name is used when
@colname is checked in 'Sort Table'.

» Text - sorts columns in order, alphabetically and by numerical value

* Number - sorts columns in order by number. Sorting pays only attention to numerical values, and entries
beginning with letters are not sorted and instead appear at the beginning or end of the range depending
on your sorting direction.

* Natural - sorts columns in a natural order, numerically and alphabetically
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Enter atab character in a table cell

» Microsoft® Excel Style - sorts columns in the same way that Excel sorts values alphanumerically
 Date - sorts values by date

In the Then Sort By sections, select additional criteria.
Example: If you sorted by Number above, and you have identical number values in your table, you can
use a second sort that places the values into a hierarchy of your choosing.

Click OK.
The table is sorted.

Enter a tab character in a table cell
You can insert a tab inside of an element in which whitespace is preserved (for example, the HTML <PRE>
element) using a macro.

© © N wDdhPRE

Switch to Plain Text view.

Click in a location where text is allowed.

Click Tools > Record New Macro.

Press Tab.

Click Tools > Stop Recording.

Complete the macro.

Switch back to Normal or Tags On view.

Position the cursor inside a table within a <PRE>-like element.
Run the macro.

Related Links

Macros on page 45
A macro is a sequence of operations that can be run as a unit. Macros can be associated with a
shortcut key, toolbar button, or menu item. They are useful when you need to repeatedly execute a
task that does not have a built-in shortcut key or command.

Inserting tables from other applications
You can copy content from other applications, such as spreadsheets and text editors, and paste it into your
document as a table.

Pasted selections are converted into a table if the following conditions are met:

There are at least two lines in the selection
Each line consists of items separated by tabs
Each line has at least two items

Each line has the same number of items

Formatting table properties
You can set formatting properties in the Table Properties dialog or the Attribute Inspector. You can also set
some formatting properties when you insert a table (HTML tables only).

To do this Follow these steps
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Format a table Place the cursor anywhere inside a table, click Table >

Format a column Place the cursor in a column, click Table > Table

Format a row Place the cursor in a row, click Table > Table Properties,

Table Properties, and select the Table tab

Properties, and select the Column tab

and select the Row tab
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Working with entities

To do this Follow these steps

Place the cursor in a cell, click Table > Table Properties,

Format a cell
and select the Cell tab

Select cells within a column or row, click Table > Table

Format a selection
Properties, and select the Selection tab

J Note: The availability of properties depends on the table model in your DTD or Schema. Changing some
of the properties may not yield visible changes to the tables.

In HTML tables, you can resize rows and columns from the Table Properties dialog box or by dragging the
row and column boundaries. In CALS tables, only columns can be resized. CALS tables support absolute
and proportional column widths, or a mix of the two. Proportional values are expressed as a number followed

by an asterisk (*).

J Tip: You can change the width of a column without affecting the width of other columns in the table by
holding down the Shift key while you drag the right edge of the column to the desired width.

Table Properties
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Cal padding: x
Lok J[ Conced J[ toay [ Heo ]

Working with entities

You can create and manage entities through the Tools menu and insert entity references through the Insert
menu. When you create an entity, an entity declaration is added to your document’s internal subset. Entities
are organized in entity sets. The list of entity sets contains all of the entities defined in the internal subset and

the DTD.

To do this Follow these steps

Click Tools > Text Entities, External Entities, or Graphic

Create an entity
Entities. Then complete the required fields and click New.

Select an entity, make the required modifications, and click

Modify an entity
Change.
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Create a text entity

To do this Follow these steps
Delete an entity Select an entity and click Delete.
Insert an entity reference Click Insert > Entity Reference, select an entity from the

available sets and click Insert.

Insert an entity reference (DITA only) Click Insert > Advanced > Entity Reference, select an
entity from the available sets and click Insert.

Open a document represented by an external entity Double-click the entity icon

Text entities are displayed as icons (for example, ) in Tags On view, and as the entity’s replacement
text (the content) in Normal view.

External entities are displayed as icons in Tags On and Normal views. You can double-click this icon to open
the corresponding file. The contents of the referenced file are parsed just as if they occurred in the current
document. Therefore, you need to ensure that the contents are valid at the location in your document.

Graphic entities are displayed as icons in Tags On and Normal views.
Graphic entities have the following content types:

« Notation. The graphic entity consists of non-SGML characters. (Almost all graphic entities are of this type.)
e Char. Data. The data in the graphic entity is not system-specific.
» Specific Char. Data. The graphic entity contains characters understood only by a local formatting system.

Entity naming conventions

Follow these rules for entity names:

 The first character of the name must be a letter.

* In SGML files, the remaining characters must be letters, digits, or the period (.) or hyphen (-). In XML files,
The underscore (_) and colon (:) are also allowed, but the colon should be avoided unless you are indicating
a namespace.

* In SGML files, names cannot be longer than 128 characters.

« A document cannot declare more than one entity with the same name, even if they are different types. If
the document declares an entity that has already been declared in the DTD, the declaration in the document
takes precedence.

» Entity names are case-sensitive. For example, ‘ProdName’ and ‘Prodname’ are considered to be different
names.

Create a text entity
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Before you begin, switch to Normal or Tags On view.

1. Click Tools > Text Entities.
2. Enter a name in the Name field.
You will use this name to refer to the entity in your document.

3. Enter the text content in the Content field.

4. Click New.
The new text entity is listed in the Text Entities field.
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Create an external entity

Create an external entity
Before you begin, switch to Normal or Tags On view.

1. Click Tools > External Entities.
2. Enter a name in the Name field.
You will use this name to refer to the entity in your document.

3. Click Choose and select a file.

4. (Optional) Enter a public identifier in the Public Name field.

5. Click New.
The new entity is listed in the File Entities field.

Create a graphic entity

Before you begin, switch to Normal or Tags On view.

E . . . .
"2/ Note: This procedure applies to SGML documents only. In order to declare a graphic entity, your DTD
must contain a corresponding NOTATION declaration.

1. Click Tools > Graphic Entities.
2. Enter a name.
You will use this name to refer to the entity in your document.
3. Click Choose and select a file.
4. Specify a content type and graphic format.
Graphic types correspond to NOTATION declarations in the DTD.

5. Click New.

Special characters and symbols

You can use the Special Characters and Symbols toolbars, or the Insert Symbols menu (displayed by using
the keyboard shortcut CTRL + Shift + S), to enter characters and symbols that do not have corresponding
keys on US English keyboards. If your document’s encoding supports it, the characters and symbols themselves
(not the character entities) are saved with your document.

The character/entity conversion table (. . \ XMet aL <ver si on>\ Aut hor\ char ent nap. xm ) is used for
mapping entity references to characters.

XML files with Unicode encoding

When you open an XML file with Unicode encoding in Tags On and Normal views, the following rules apply,
in the following order:

1. The entity references for the characters ‘<’, *>', and ‘&’ are rendered as characters.

2. Other entity references are rendered as characters if they are included in the character/entity conversion
table, and if your operating system and version of XMetaL Author are capable of displaying the character.

When you save an XML file with Unicode encoding, the following rules apply, in the following order:

1. The characters ‘'<’, *>’, and ‘&’ are converted to entity references.
2. If the document encoding allows it, other characters are saved as actual characters.
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Inserting CDATA sections

3. If not, and if the character/entity conversion table has a corresponding entity reference, the character is
saved as an entity reference.

4. If none of the above apply, the character is saved as a character reference.

SGML files with Unicode encoding

When you open an SGML file with Unicode encoding, entity references are converted to actual characters if
they included in the character/entity conversion table, and if your operating system and version of XMetalL
Author are capable of displaying the character.

When you save an SGML file with Unicode encoding, the characters are saved according to the following
rules, in the following order:

1. If the character/entity conversion table has an corresponding entity reference, the character is saved as
an entity reference.

2. If not, and if the document encoding allows for it, characters are saved as actual characters.
3. If neither of the above applies, the character is saved as a character reference.

Files with ASCII or ISO-8859-1 encoding

For files with ASCII or ISO-8859-1 encoding, non-ASCII or non-1ISO-8859-1 characters are saved as entity
references if they are in the character/entity conversion table, and as character references if they are not.

Related Links

Character encoding on page 61
XMetaL Author supports US-ASCII, ISO-8859-1 (Latin-1), and Unicode™ (UTF-8 or UTF-16) character
encoding. By default, XML files that you create with XMetalL Author use UTF-8 encoding.

Inserting CDATA sections
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You can insert CDATA sections using the Insert menu.

To do this Follow these steps
Insert a CDATA section (not available in DITA) Click Insert > CDATA Section
Insert a CDATA section (DITA only) Click Insert > Advanced > CDATA Section

e Tip: You can also wrap selected text in a CDATA section using the procedures above.

) camerasinFocus.xml

Introductior]_

[EFara> The newest generation D'f_ [E[EEATAL» affordable, @h_.i'g}:—msn'lun'nn digital cameras
delivers prints that are nearly indistinguishable fromrtraditional film based photos. Over the
past year, the entry level $500 digital camera has gone from a 640 by 480 resolution that
delivered a reasonable 4 by 6 inch print to a 1,280 by 1,024 resolution that delivers an excellent

5 7111[‘]1 , "“‘“‘*"\““‘*-N‘l".ﬁw’ﬂ-"ﬂ r‘
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Inserting comments

Other marked sections
In SGML documents, you can change the CDATA keyword or add other keywords in Plain Text view. When
you use keywords concurrently, the following order of precedence applies:

1. IGNORE
2. CDATA

3. RCDATA
4. INCLUDE

TEMP is not overridden by any other keyword.
INCLUDE is the default for all marked sections.

Inserting comments

You can insert comments using the Insert menu. Comments can be viewed in Tags On view if the Show
comments option is active.

To do this Follow these steps
Insert a comment (not available in DITA) Click Insert > Comment
Insert a comment (DITA only) Click Insert > Advanced > Comment

e Tip: You can also change selected text to a comment using the procedures above.

) CamerasinFocus.xml

--Introductlon@

[EPar> The newest generation of -aﬁordable @lﬂgb resolution digital cameras delivers
prints that are nearly indistinguishable from traditioral film based photos. Over the past year,
the entrv level $500 digital camera has gone from a 640 by 480 resolution that delivered a
reasonable 4 by & inch print to a 1,280 by 1,024 resolution that delivers an excellent 5 by 7 inch

L, \m w&-q_.\ HA\‘ . )\\_wﬁ_‘ ‘ﬁu.-.~ """‘“""\--—-n\_ r“‘~" ’

Related Links
Options on page 49
You can set options through the Tools menu.

Inserting processing instructions

You can insert processing instructions using the Insert menu. Processing instructions are commonly used
to store prompt text.

To do this Follow these steps
Insert a processing instruction (not in DITA) Click Insert > Processing Instruction
Insert a processing instruction (DITA only) Click Insert > Advanced > Processing Instruction
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Importing databases

You can import the contents of a database or spreadsheet file into your structured document as a table. When
you import a database, you create an SQL query that allows you to import only the data you need and in the
format you want. When you import data, you apply elements and attributes that are used in your DTD or
Schema.

Most customizations include a menu command or a toolbar button you can use to open the Import Database
dialog box. For example, the Journalist customization includes the following macros:

 Import Table
» Update Table

When you run the Import Table macro, the Import Database dialog box opens. This is the interface for selecting
your data, creating your query, and formatting output.

After you import data into your XMetaL Author document, you can update it (reload the data from the source
database) using the Update Table macro.

Impart Database E

Distabase

Type | Microssit Excal Deiver [*xds)
Select
Mame |C:\Program Filee'Metal 5. 1\Author\\Samples’\Camer

Guery Bulder | \iew S0L | Data Preview | Output Format

Tables Aorsilable Fields

v
(e ]

Selected Fiakia

Reld Display Mama Show | Sod Rker Condition
Sheet 1STABLE Fe.. Features Yes
Sheet1STABLE Sy.. Syna RM-ED AL
Sheet 1STABLE Ku... Kukama MoT5.. Yes
Sheet1STABLERJ.. RJR HappyCa . Ves

Edit | | Remeve | |R¢='m:\'=v'-\ll

| Ok ] l Cancel | | Help ]

Related Links

Macros on page 45
A macro is a sequence of operations that can be run as a unit. Macros can be associated with a
shortcut key, toolbar button, or menu item. They are useful when you need to repeatedly execute a
task that does not have a built-in shortcut key or command.

Choosing a database

The source database can be afile, a folder, or a DSN (Data Source Name). You can choose a database from
the Select Database dialog box.
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Creating a query

To do this Follow these steps

Select a database file or folder In the Import Database dialog, click Select. Select the
Driver option and choose a driver. If you select a Microsoft
Access or Microsoft Excel driver, choose the File option. If
you select any other driver, select the Folder option. Then
click the browse button and select the database file or folder.

Selec